UEFI boot hangs at purple screen if NIC activated

Bug #1093472 reported by mlaverdiere on 2012-12-24
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm trying to boot Ubuntu 12.10 64 bits on UEFI mode on a Dell Inspiron 14z ultrabook with an integrated Atheros AR8162 ethernet card (NIC).

If the AR8162 card is enabled in BIOS, Ubuntu won't load, as it will hang in a blank purple screen or, in recovery mode, at "loading initial ramdisk". If the AR8162 card is disabled, it will boot just fine.

What is strange is that I'm able to boot the same Ubuntu installation in legacy mode with the AR8162 enabled in BIOS and this card is working just fine with the alx module available in compat-wireless package (see: http://askubuntu.com/questions/157223/12-04-does-not-detect-eth0atheros-ar8162/231715#231715).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub-efi 2.00-7ubuntu11
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
Date: Mon Dec 24 10:00:44 2012
InstallationDate: Installed on 2012-12-14 (10 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

mlaverdiere (mlaverdiere) wrote :
description: updated
mlaverdiere (mlaverdiere) wrote :

Here are further results:

-Using rEFInd to boot directly the linux kernel doesn't work either, so it's probably not a grub bug.
-With Fedora 18 beta 64 bits, I get the same results, i.e. freeze if NIC is activated.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Markus Neteler (neteler) wrote :

FYI:
For the Atheros AR8162 ethernet card and Fedora, see also
https://bugzilla.redhat.com/show_bug.cgi?id=842367#c15 and later

Rafael Keller Tesser (rktesser) wrote :

I have the same bug in ubuntu 13.04 with:
grub-efi-amd64 version 2.00-13ubuntu3

I tried to boot in recovery mode with the options debug=all and pager=1 in grub. A picture showing where the freeze happens is attached. The freeze seems to happen after thte initial ram disk is loaded.
When starting with the NIC disabled, the messages seem to be the same. The difference is that, after the point where the freeze happens, grub seems to hands over the control of the system to the kernel and the boot process continues on.

Steve Langasek (vorlon) on 2013-05-11
no longer affects: shim-signed (Ubuntu)
Kazi Tawhid (tau) wrote :

Same bug occurred with Toshiba P845t.
Thanks to mlaverdiere to figure out the workaround.

Patrick Sheridan (sheridp) wrote :

Sorry if obvious, but what is the workaround? I am still having this issue in 13.04, booting with UEFI; is the only solution to do a legacy boot? Thanks.

L T (lt-83) wrote :

I have also come across this issue with a different system. I have a Toshiba A55-S5279 laptop. When booting via UEFI with the NIC card enabled in the BIOS, it hangs on a black screen before the Ubuntu logo shows up. When I disable the NIC card under UEFI, it boots successfully.

It also boots successfully when I am booting under CSM mode with or without the network card.

lspci reports that the Ethernet controller is:
04:00.0 Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)

Only some users reported the network card, unless others had a different NIC manufacturer, it seems that the issue might be isolated to Atheros chipsets booting from UEFI.

I also have a Dell Inspiron 14z ultrabook with an integrated Atheros AR8162 Ethernet card and a AR9485 Network controller.

I can boot with Ubuntu 13.04 from a USB pendrive in legacy mode, but I couldn't in UEFI mode.
I tried all settings using F12 in the boot, and when I disabled the NIC it worked.

I installed Ubuntu 13.04 in legacy mode, that runs ok, but it can not run in UEFI mode.
But, again, if I disable the NIC, it works.

It's interesting that even with the NIC disabled, I can access Internet.

Any solution?

Diego (diecarabajal) wrote :

Hi, I have the same problem.

I also have a Dell Inspiron 14z ultrabook with an integrated Atheros AR8162 . I installed ubuntu 13.10, but I have to run it in the bios disabled the network card.

Someone find the solution to this problem?

Patrick Sheridan (sheridp) wrote :

Not a fix, but a workaround is just to use legacy boot (MBR) instead of UEFI.

Diego (diecarabajal) wrote :

Ok, thank you very much.

Today I'm going to try.

Anyway, anyone know what the cause of this failure?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.