Wrong grub-efi resolution during OS boot menu selection

Bug #1086289 reported by Nikki1993 on 2012-12-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned

Bug Description

So I recently decided to try to install windows 7 and ubuntu 12.10 in UEFI mode and succeeded in doing that. Both system load as the should and everything work perfectly but there is one thing that keeps bothering me and it is grub resolution.
Before that I was using dual boot system Ubuntu and Windows in BIOS mode and grub resolution was correct 1366x768 (which is my native resolution) After reinstalling both OS in UEFI mode grub resolution became wrong (which I assume is 640x480) BUT Splash screen resolution on boot and shutdown is CORRECT (1366x768). Only grub boot menu is incorrect.

What I tried:
editing sudo gedit /etc/default/grub
and uncommenting GRUB_GFXMODE + setting resolution 1366x768 DIDN'T WORK

Tried to edit line above + sudo gedit /etc/grub.d/00_header where I add line
set gfxpayload=keep under line set gfxmode=${GRUB_GFXMODE} DIDN'T WORK.

So I consider that to be a bug cause again when I had both systems installed in BIOS mode my resolution was correct in grub menu.

I am running ASUS laptop K53SV
intel HD 3000 + Nvidia Optimus GeForce GT (bumblebee installed)
+ xorg edgers ppa (so all drivers are up-to date)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub-efi 2.00-7ubuntu11
ProcVersionSignature: Ubuntu 3.7.0-4.12-generic 3.7.0-rc7
Uname: Linux 3.7.0-4-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Tue Dec 4 10:26:44 2012
InstallationDate: Installed on 2012-11-30 (3 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Nikki1993 (nikki-icekronik) wrote :
summary: - Wrong grub-efi resolution during boot menu seleection
+ Wrong grub-efi resolution during OS boot menu selection
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Henry Rouhivuori (henry-pirat) wrote :

On my older machines (Samsung netbook and a Zotac Box) grub-efi resolution is wrong 640x480. In this Acer One 725 grub-efi resolution is full 1366x768.

Ubfan (ubfan1) wrote :

I have seen the reduced grub resolution, but only after an EFI boot failure and its subsequent fallback to the /Boot/bootx64.efi.
My machine is a Toshiba Satellite S855, and it boots off USB with a correctly set up ESP at full resolution, but when I select the hard disk's ubuntu choice, I got the reduced resolution. Examining the actual hard disk ubuntu boot path, it was ...ubuntu/grubx674.efi, which is wrong for a secure boot (which I use). It should be ...ubuntu/shim.efi. The ...Boot/bootx64.efi contained a copy of the shim.efi, and when the bootx64 file was removed, the boot failed. I conclude that the first boot attempt to grubx64 directly silently failed, then EFI tried the Boot/bootx64 and succeeded in starting shim, which started grub -- at the wrong resolution.
  I'd suggest checking your boot path with
sudo efibootmgr -v
and confirm that it is what you think it is. So much renaming of these files can occur that looking at the sizes is necessary to confirm their identity. There are signed and unsigned versions of grubx64, and only the correct one will work. As an example of this sequence of errors on a non-secure boot machine, suppose the bootx64 contains copy of the non-signed grubx64 (which will work), but the boot path is to ubuntu/grubx64 which is the signed version.
  I have not bothered to correct the boot path, since I don't notice any delays, and the resolution doesn't bother me, so I may be totally wrong that correcting the initial boot path will fix things. Also I feel I need to learn more about NVRAM and how to determine how much free space is available before adding things to it like new boot choices -- the Samsung situation of too little NVRAM makes me cautious, afraid I'll brick my machine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers