ubuntu-defaults-builder: only quantal 64bit does not build

Bug #1075876 reported by Redmar on 2012-11-07
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
ubuntu-defaults-builder (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

The example for ubuntu-defaults-builder does not build:

By following the man page:
/usr/share/doc/ubuntu-defaults-builder/examples/make-example
ubuntu-defaults-image --package ./defaults-builder-test_0.1_all.deb --components main,restricted,universe

Final part of the logfile:

Rebuilding /usr/share/applications/bamf.index...
Errors were encountered while processing:
 linux-image-3.5.0-17-generic
 linux-image-extra-3.5.0-17-generic
 linux-signed-image-3.5.0-17-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...
Reading state information...

I will attach the complete log

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubuntu-defaults-builder 0.44
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Wed Nov 7 08:40:35 2012
InstallationDate: Installed on 2012-04-28 (192 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120426-23:52
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-defaults-builder
UpgradeStatus: Upgraded to quantal on 2012-09-13 (54 days ago)

Redmar (redmar) wrote :
Redmar (redmar) wrote :
Redmar (redmar) wrote :

It looks like this affects all builds, since building with theDutch customization package also fails

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-defaults-builder (Ubuntu):
status: New → Confirmed
Csaba Pető (phace) wrote :

Same problem with ubuntu-defaults-builder 0.45.
DistroRelease: Ubuntu 12.10 64 bit

Redmar (redmar) wrote :

I've done some more testing, and it appears this only happens for building Quantal 64 bit, no matter which customizations are used. For example, building the example on Q64bit with --arch i368 works, building on Q32 with --arch amd64 fails.

I'll test if this bug occurs for raring next

Redmar (redmar) wrote :

This bug does not occur for raring, 32 or 64 bit.

summary: - ubuntu-defaults-builder: example does not build
+ ubuntu-defaults-builder: only quantal 64bit does not build
Jean-Baptiste Lallement (jibel) wrote :

Error message from the logs:
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.5.0-17-generic /boot/vmlinuz-3.5.0-17-generic
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.5.0-17-generic.postinst line 1010.
dpkg: error processing linux-image-3.5.0-17-generic (--configure):
 subprocess installed post-installation script returned error exit status 2

Closing Raring task since it occurs only on Quantal

Changed in ubuntu-defaults-builder (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-defaults-builder (Ubuntu Quantal):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I see the following error:
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).

This appears to be an issue with grub versus the kernel. I'll add a grub2 bug task for review.

tags: added: kernel-da-key
Redmar (redmar) wrote :

The following error:
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?)

also occurs in succesfull builds, so it would seem this is not a fatal error. I've also attached the log for a succesfull Quantal 32 bit build. This image was build on up-to-date raring.

Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in ubuntu-defaults-builder (Ubuntu Quantal):
status: Confirmed → Won't Fix
Changed in grub2 (Ubuntu Quantal):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers