USB keyboard is not recognized on mac mini during the grub menu

Bug #1050436 reported by Para Siva on 2012-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
High
Unassigned

Bug Description

After installing two side-by-side quantal installations with 20120913.1 - amd64+mac desktop on a mac mini, it is impossible to boot to the first quantal installation.

Pressing down arrow key at the grub menu does not change anything and the menu timesout with the default 10 seconds and boots with the latest (second in this case) ubuntu installation.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-14-generic 3.5.0-14.16
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
AcpiTables: Error: command ['pkexec', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code 127: Error executing /usr/share/apport/dump_acpi_tables.py: Permission denied
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu2 1873 F.... pulseaudio
Date: Thu Sep 13 14:41:59 2012
HibernationDevice: RESUME=UUID=e62441a3-3cab-4c4d-b104-51d6c90a7d63
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64+mac (20120913.1)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Apple Inc. Macmini5,1
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-14-generic root=UUID=8fded063-1ef0-4918-8e41-c9a45bb40620 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-14-generic N/A
 linux-backports-modules-3.5.0-14-generic N/A
 linux-firmware 1.91
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/20/2011
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MM51.88Z.0077.B0F.1110201309
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-8ED6AF5B48C039E1
dmi.board.vendor: Apple Inc.
dmi.board.version: Macmini5,1
dmi.chassis.type: 16
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-8ED6AF5B48C039E1
dmi.modalias: dmi:bvnAppleInc.:bvrMM51.88Z.0077.B0F.1110201309:bd10/20/2011:svnAppleInc.:pnMacmini5,1:pvr1.0:rvnAppleInc.:rnMac-8ED6AF5B48C039E1:rvrMacmini5,1:cvnAppleInc.:ct16:cvrMac-8ED6AF5B48C039E1:
dmi.product.name: Macmini5,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Para Siva (psivaa) wrote :
Brad Figg (brad-figg) on 2012-09-13
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you follow the "Boot options" instructions on the following wiki to enable additional output on boot:

https://wiki.ubuntu.com/DebuggingKernelBoot

As mentioned on the wiki, it would be great if you can attach a log file which may have captured any messages you see. If you are unable to capture a log file, a digital photo will work just as well. As a last resort you can even copy messages down by hand.

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Para Siva (psivaa) wrote :

The issue is with navigating to the kernel entry that I want to boot. So I could not go pass the step 3 on the above wiki. I am attaching a photo of the grub menu if it helps.

Tried to press 'e' to see if the latest installed kernel boot option could be changed but pressing 'e' does not do anything either

tags: added: kernel-da-key
Jean-Baptiste Lallement (jibel) wrote :

reassigned to grub2 per conversation on IRC with psivaa

affects: linux (Ubuntu) → grub2 (Ubuntu)
Para Siva (psivaa) on 2012-09-14
summary: - Up/Down arrow keys are not recognized during the grub menu on amd64+mac
+ USB keyboard is not recognized on mac mini during the grub menu
Para Siva (psivaa) wrote :

Changed the title of the bug because the late findings indicate that none of the keystrokes are recognized. Even with single boot, having forced the grub menu to be displayed with the GRUB_TIMEOUT= -1, there is no way of getting it boot with any kernel due to not being able to select any kernel. nor being able to hit enter to boot with the defaults one. (=0)

Colin Watson (cjwatson) wrote :

I expect this was with GRUB 1.99. Please try GRUB 2.00 in today's images and see whether that helps; there's a decent chance that it will, as EHCI support has been added.

Para Siva (psivaa) wrote :

I tried this with today's image, 20120914, with b6565ad153301deb66ed38257ae104fe md5sum and the issue is still there. (with GNU GRUB version 2.00-3ubuntu1)

Para Siva (psivaa) on 2012-09-17
tags: added: rls-q-incoming
Colin Watson (cjwatson) wrote :

This happens in precise as well, and I've tried the one promising-looking post-2.00 upstream patch (r4559) with no luck. That means that it's not a regression, and is likely a long-standing lack of upstream support for some particular USB device. We are unlikely going to be able to fix this for quantal; I expect a GRUB developer needs to get their hands on an affected system when they have a spare day or two. Thus, tagging rls-q-notfixing.

tags: added: rls-q-notfixing
removed: rls-q-incoming
Changed in grub2 (Ubuntu):
status: Confirmed → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1050436

tags: added: iso-testing
Para Siva (psivaa) wrote :

In the process of trying this with another keyboard

Para Siva (psivaa) wrote :

Tried with Targus Compact USB keyboard and with quantal-desktop-amd64+mac 20120925 and it worked fine in the grub menu, i was able to select an earlier installed kernel to boot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers