grub-install fails

Bug #1048989 reported by YannUbuntu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

Reported by Tom by email.

12.04 install.
Dell Inspiron 910.
From a liveCD, reinstalling GRUB fails:

ubuntu@ubuntu:~$ sudo mount /dev/sda1 /media
mount: /dev/sda1 already mounted or /media busy
mount: according to mtab, /dev/sda1 is already mounted on /media
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ for w in dev dev/pts proc sys; do sudo mount -B /$w
/media/$w ; done
ubuntu@ubuntu:~$
ubuntu@ubuntu:~$ sudo chroot /media grub-install /dev/sda
/usr/sbin/grub-setup: error: cannot write to `/dev/sda'.

Same error when trying to reinstall GRUB via Boot-Repair: http://paste.ubuntu.com/1192496/

YannUbuntu (yannubuntu)
description: updated
Revision history for this message
Phillip Susi (psusi) wrote :

Does dmesg show any errors after this?

Changed in grub2 (Ubuntu):
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
Revision history for this message
YannUbuntu (yannubuntu) wrote :

FYI, the user (Tom) wrote:

"So I started back from scratch. I wiped the system and reinstalled
10.4 LTS with a stock lilo loader. Then I followed the update-upgrade
link to to 12.04. That worked.

The netbook now works, though I am stuck with the ineligance of lilo.
But my Dell Inspiron 910 is now working well enough"

description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers