grub-efi 32 bits fails on 64bits computer

Bug #1020446 reported by YannUbuntu
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

On a 64bits EFI computer (with GPT disk) with pre-installed 64bits Windows7. Laptop ASUS N76VZ-V2G-T1002V.

1) Installed Ubuntu 12.04 32bits in dual-boot, then installed grub-efi. Result: http://paste.ubuntu.com/1069331 (see the 3 efi files on sda1). At reboot, GRUB menu does not appear, even when setting the EFI BIOS on /efi/ubuntu/boot.efi , or /efi/ubuntu/grubia32.efi .

2) Removed the Ubuntu32bits partitions, and replaced it by Ubuntu 64bits. Result: http://paste.ubuntu.com/1072125 (see the new /efi/ubuntu/grubx64.efi file). At reboot, the GRUB menu appears and allows to boot Ubuntu.

Original thread in French: http://forum.ubuntu-fr.org/viewtopic.php?pid=9878051#p9878051

Don't hesitate to ask more informations.

Revision history for this message
YannUbuntu (yannubuntu) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan (miareggeti) wrote :

Mounting the EFI partition as /boot/efi (fat32 filesystem) and maunally installing grub-efi (through chroot) makes a valid entry in the EFI partition.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
YannUbuntu (yannubuntu) wrote :

Jonathan,
This bug is about 64-bit computers, so it is not duplicate of "Ubuntu i386 images are not compatible with 32-bit UEFI computers.".

Concerning your remark, are you saying that you have a grubia32.efi entry allowing to boot Ubuntu on a 64-bit computer?
If yes, please could you indicate the Boot-Info URL ?

Changed in grub2 (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Phillip Susi (psusi) wrote :

As stated this doesn't make sense. As the other bugs note, the 32 bit cd can't boot in efi mode and can't install grub-efi. Did you manually install grub-efi? Unless you did something like that, then the installer would have put grub-pc on the system.

Changed in grub2 (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
YannUbuntu (yannubuntu) wrote :

Hi Phillip,
yes, grub-efi was installed manually after the Ubuntu-32bit install.

description: updated
Changed in grub2 (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Phillip Susi (psusi) wrote :

A 64 bit UEFI firmware generally will only load a 64 bit boot loader. This is a limitation of the firmware, not grub. If you want to run a 32 bit OS on a 64 bit UEFI system, you have to switch it to legacy mode.

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
YannUbuntu (yannubuntu) wrote :

ok, thank you.
That's another reason to make Ubiquity refusing (or advising not) to install Ubuntu-32bit on a 64-bit UEFI computer... ;)

Revision history for this message
YannUbuntu (yannubuntu) wrote :

Phillip, please could you provide sources/links showing that "64 bit UEFI firmware generally will only load a 64 bit boot loader, by firmware limitation" ?
or if this is just personal experience, please could you indicate which firmware/computers you have seen with this limitation ?

Revision history for this message
Phillip Susi (psusi) wrote :

I actually came across a blog entry by Matthew Garret ( redhat kernel guru ) today pleading to hardware vendors not to release 32 bit uefi only systems where he states the same thing:

http://mjg59.dreamwidth.org/26734.html

I looked over the UEFI specs a bit today too and came to the conclusion that it is technically possible for a UEFI firmware to support both 32 and 64 bit, I would be difficult with no real gain so I would be very surprised to see anyone do it. After all, the target platform of choice ( Windows ) only supports UEFI on the 64 bit release and 32 bit operating systems can boot just fine in legacy mode so there just isn't any incentive to make a dual arch firmware.

Revision history for this message
YannUbuntu (yannubuntu) wrote :

thank you Phillip.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers