grub2 does not look for splash images in default grub2-splashimages location

Bug #299861 reported by Niall Creech
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Low
Unassigned
Nominated for Lucid by Thomas
grub2-splashimages (Ubuntu)
Low
Unassigned
Nominated for Lucid by Thomas

Bug Description

Binary package hint: grub2

the default search in /etc/grub.d/05_debian_theme seems to be

{/boot/grub,/usr/share/images/desktop-base}/WhateverSplashImageYouWant.{png,tga}

but the images i get from grub2-splashimages are in /usr/share/images/grub

changing that line 16 to

  for i in {/boot/grub,/usr/share/images/desktop-base,/usr/share/images/grub}/WhateverSplashImageYouWant.{png,tga} ; do

fixes the /etc/grub/grub.conf generated from update-grub2 to find the splash though

Revision history for this message
Alex Valavanis (valavanisalex) wrote :

I can confirm this, but I'm not sure whether the bug belongs to the grub2 package or to grub2-splashimages. On a default installation, the /usr/share/images/grub path doesn't exist, so I guess it's the job of the grub2-splashimages installation script to add the path to /etc/grub.d/05_debian_theme when it becomes needed.

Changed in grub2 (Ubuntu):
importance: Undecided → Low
Revision history for this message
MM (mmme) wrote :

In /etc/grub.d/05_debian_theme I have this:

for i in {/boot/grub,/usr/share/images/desktop-base}/Windbuchencom.{png,tga} ; do

The grub2-splash get installed into /usr/share/images/grub/.

So what I've done for now to fix the problem is add in the path: (/usr/share/images/grub)

for i in {/boot/grub,/usr/share/images/grub,/usr/share/images/desktop-base}/Windbuchencom.{png,tga} ; do

Leaving the images in /usr/share/images/grub/ isn't working, unless you add the path into /etc/grub.d/05_debian_theme

Rolf Leggewie (r0lf)
Changed in grub2-splashimages (Ubuntu):
status: New → Confirmed
Changed in grub2 (Ubuntu):
status: New → Confirmed
Changed in grub2-splashimages (Ubuntu):
importance: Undecided → Low
Revision history for this message
Colin Watson (cjwatson) wrote :

This should be easier with the new 05_debian_theme introduced recently in Natty. With that, you can set GRUB_BACKGROUND="/usr/share/images/grub/Windbuchencom.tga" (or similar) in /etc/default/grub and run 'sudo update-grub'.

grub2-splashimages' documentation should still be updated to match.

Changed in grub2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers