3.19.0-22 won't display on Lenovo

Bug #1474342 reported by Ilan Tal
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2-signed (Ubuntu)
Undecided
Unassigned

Bug Description

My Lenovo G585 computer won't boot correctly since the upgrade from 3.19.0-20 to 3.19.0-22.
In the boot there is a stage where it is supposed to show me my username and ask for a password.
The screen is totally blank. I hear the sound so I know I am supposed to enter my password, but I see a blank screen.
I enter my password and I will continue to see only a blank screen, but I can hear the skype sound as it continues the process of booting. I am convinced that all is working, just I see absolutely nothing.
I was convinced something on the motherboard went bad and I would need to buy a new computer.
Before that I tried to boot up in recovery mode. That worked fine and made me guess that perhaps the high resolution of the screen had died.

Finally I dropped down to 3.19.0-20 and everything worked like a charm, full resolution, no problems at all.
So, the next step was to boot via 3.19.0-22 and it was back to a blank screen.

I don't know if it is connected to my laptop or if it is more general, but 3.19.0-22 is dead in the water for me.
If there is anything I can do to help, please let me know.

Thanks,
Ilan

Revision history for this message
Ilan Tal (ilan-tal) wrote :

There is something I remember which may influence the bug.
Usually when there is a new kernel I do an immediate restart.
Yesterday after I was done updating to the new kernel, I had nothing more to do on the computer.
Thus instead of a Restart I did a Shut down.
This morning when I turned on the computer I got the blank screen problem.

Could that have a connection to the problem?

Revision history for this message
Ilan Tal (ilan-tal) wrote :

This morning I updated to 3.19.0-23 and the problem exists on the latest kernel as well.
The only way I can work is to drop back to 3.19.0-20
Any suggestions?

Revision history for this message
Ilan Tal (ilan-tal) wrote :

This morning there was a new kernel 3.19.0-25 so I updated again. The problem still exists.
While trying to do the update I noticed that 3.19.0-20 had some problem with aport.grub (not sure of the spelling).
Since the problem is at boot I decide to drop back to 3.19.0-18 which reported no errors.
Now perhaps the update would work?

No luck and the list of bad kernels keeps getting longer and longer. If the system decides to wipe out my old kernels I will really be dead in the water.
Can anyone give me some help?

Thanks,
Ilan

Revision history for this message
Ilan Tal (ilan-tal) wrote :
Revision history for this message
Paul White  (paulw2u) wrote :

As the issue as been reported as solved will mark as "Invalid".

Changed in grub2-signed (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers