kubuntu upgrade and kernel updates mess up grub config

Bug #94066 reported by gaunt on 2007-03-20
6
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6-386

For my menu.1st to be working it has to have the following lines:
root (hd0,4)
kernel /boot/vmlinuz-2.6.20-12-386 root=/dev/hda5 ro quiet splash

These line were added by kubuntu when installing 6.06

After every kernel update and also now with the 7.04 upgrade these lines are changed to:
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-12-386 root=/dev/evms/hda5 ro quiet splash
(note the evms part)

which obviously does not work.

ProblemType: Bug
Architecture: i386
Date: Tue Mar 20 12:50:46 2007
DistroRelease: Ubuntu 7.04
Uname: Linux pme-desktop 2.6.20-12-386 #2 Sun Mar 18 03:04:09 UTC 2007 i686 GNU/Linux

gaunt (meisel-denkformat) wrote :

With the latest updates the "evms" issue is gone due to the fact that now UUIDs are being used (still dont like them). But the root=(hd0,0) issue persists. Please note that these lines have been added by ubuntu during install so i guess they should be ok in the automagic part.

Gaetan Nadon (memsize) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 8497, so it is being marked as such. There is a comment there to the effect that is fixed in 8.10. Reassigning to grub to match original bug report. Any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.
BugSquad

Changed in linux-meta:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers