xubuntu dapper 6.06 to edgy 6.10 dist-upgrade failed (kernel postinst failure)

Bug #63074 reported by txarlix on 2006-09-29
14
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
High
Michael Vogt

Bug Description

Once I was updating my xubuntu drapper 6.06 to edgy 6.10 the process did not end succesfully: It generated three log at /var/log/dist-upgrade/
apt.log main.log term.log

Edit: Sorry, here are the files. :)

[summary was: System instable: 3 log in /var/log/dist-upgrade]

Related branches

John Vivirito (gnomefreak) wrote :

Can you please attach the files instead of pasting them on the page. Thank you.

txarlix (chals) wrote :

To attach the files

description: updated
txarlix (chals) wrote :

2nd file

txarlix (chals) wrote :

3rd file

I saw these lines in apt.log:
"Package xubuntu-desktop has broken dep on xorg
  Considering xorg 1 as a solution to xubuntu-desktop 0
  Removing xubuntu-desktop rather than change xorg"

so I took the liberty to change the summary of the bug.

description: updated
John Vivirito (gnomefreak) wrote :

ok can you install xorg by running "sudo apt-get install xorg" does it install xorg?

Michael Vogt (mvo) on 2006-10-02
Changed in apt:
importance: Undecided → High
status: Unconfirmed → Confirmed
txarlix (chals) wrote :

Not that way, it says xorg is already install. I run "sudo apt-get install xorg --reinstall" and xorg was reinstalled, but when I rebooted the system, xfce didn't work. Just typing "alt+F1" Firefox beta 2 run perfectly, nothing else. The only way to get out from xfce is typing "ctrl+alt+BkSp" And it lets me get in gnome session.

Michael Vogt (mvo) wrote :

Can you please add the output of:
$ df -h
to this bugreport?

Thanks,
 Michael

txarlix (chals) wrote :

My system is intalled in spanish. Here is the output of:
$ df -h
S.ficheros Tamaño Usado Disp Uso% Montado en
/dev/hda2 6,8G 3,0G 3,5G 47% /
varrun 78M 84K 78M 1% /var/run
varlock 78M 4,0K 78M 1% /var/lock
udev 10M 100K 10M 1% /dev
devshm 78M 0K 78M 0% /dev/shm
lrm 78M 18M 60M 23% /lib/moduls/2.6.17-10-386/volatile
/dev/hda1 243M 31M 199M 14% /boot
/dev/hda5 941M 24M 867M 3 % /home
/dev/hda3 8,8G 1,6G 7,2G 9% /media/hda3
/dev/hda6 1,3G 256K 1,3G 11% /media/hda6
$_

Michael Vogt (mvo) wrote :

This turned out to be a update-grub bug.

Changed in linux-source-2.6.17:
assignee: nobody → mvo
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

This is fixed with the upload of grub 0.97-11ubuntu13. There were two places were update-grub still wrote to stdout, confusing debconf and make the postinst fail.

Changed in grub:
status: In Progress → Fix Released
txarlix (chals) wrote :

So, how can I fix my sistem. What comand sould I run?

Thanks. ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers