Grub refuses to boot after fresh installation

Bug #62847 reported by Peter Frost on 2006-09-28
2
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

Not sure whether this is a Grub bug or an installer one, to be honest.

I just tried to install Dapper (server edition) on my fileserver. It has previously been running Breezy, under which Grub booted the kernel just fine.

I have tried telling the installer to use the existing partitions, and then to generate its own. The problem occurs either way.

When I boot the server I see the following message from Grub:
-----

root (hd4,0)
  Filesystem type is ext2fs, partition type 0x83
  kernel /boot/vmlinuz-2.6.15-26-server root=/dev/hde1 ro quiet splash

Error 24: Attempt to access block outside partition

-----

Grub appears to be looking at the correct hard disk (a 40GB Seagate with both root and swap partitions on it).

The server contains 4 x 160GB WD hard disks (attached to a SIL PATA RAID card which is configured as if it were just another IDE controller) and 1 x 40GB Seagate PATA hard disk (which is the main boot device, though it shows up as the fifth drive in the system).

fdisk prints the following partition table for the boot drive (this is the table which was automatically generated by the installer):

-----

Disk /dev/hde: 40.0GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hde1 * 1 4772 38331058+ 83 Linux
/dev/hde2 4773 4865 747022+ 5 Extended
/dev/hde5 4773 4865 746991 82 Linux swap/Solaris

-----

Peter Frost (slimeypete) wrote :

I have found the root of the problem: Grub sees the boot drive as hd(0) but the installer has told it to look at hd(4). Manually configuring Grub to look at hd(0) results in a bootable system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers