"Single User mode" should be renamed

Bug #62600 reported by Aaron Whitehouse on 2006-09-27
6
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Scott James Remnant (Canonical)

Bug Description

I have been using Ubuntu since Hoary, so I am used to the general way that Ubuntu works. I was quite confused, however, when I installed Edgy (Knot 3) and reached the Grub menu.

After some thought on the matter, I decided that the top one was likely for me because it had been in every previous Ubuntu and there is usually a rescue mode in position two.

The reason that I was confused is that I use Ubuntu as a desktop OS and am the only user for my machine. My first interpretation of "Single User" was that it was optimised for installations like mine; one user using Ubuntu as a desktop. I have since found out that it is the "Rescue" or "Safe" mode.

I understand that there are reasons that "Single User" is used, but I personally would like to change the name to "Rescue Mode" to avoid other, less technical, people making the same misinterpretation that I fell prey to. This will especially affect desktop users because they will be the ones that think the second option best describes their situation.

Colin Watson (cjwatson) wrote :

The term "rescue mode" would be pretty confusing, as there's an entirely different "rescue mode" on the alternate install CD. I agree that "single user" is not necessarily the best term to use, though - it's technically accurate but (as you observe) confusing.

Changed in grub:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Jonathan Austin (mailforwho) wrote :

This will certainly affect people that I have installed Ubuntu for who see themeselves as a single user - to choose the second option makes more sense and will make them think they will be able to avoid things like logging in (which most real single users regard as unnecessary hassle, as far as I see)...

In my rather unscientific survey of 3 people who use Ubuntu but don't maintain/know about it 2/3 said they would have chosen single user mode.... This is confusion we can so easily avoid

How about 'Maintainence Mode', 'Administration Mode', 'Repair Mode', 'Administrator/Terminal Mode' or 'Root with No Graphics'

I prefer the first or last options, presonally

Eric Butler (codebutler) wrote :

"Administration Console Only"?

avizcarra (alviz) wrote :

I agree with change that entry, I'll prefer "Advance User" or "text mode",i am a new user -since May 06- and I'd like to see a new graphic interface for grub (it's 21 century!!!) for example my first installation was Xandros (I don't know how i got it) but, the point is :Lilo on that distro have a nice interfaz, and it's configureable on desktop enviroment without type any command in console.

regards!

pd sorry for my english. MX

Matt Zimmerman (mdz) wrote :

It has been called "recovery mode" in Ubuntu (including in the grub menu in the past). This is a regression and should be fixed for edgy final as documentation refers to recovery mode.

Changed in grub:
assignee: nobody → keybuk
importance: Low → Medium
Matt Zimmerman (mdz) wrote :

<sladen> ah, a *Debian* fix (debian #370110) changed "from recovery mode to single-user"
<Ubugtu> Debian bug 370110 in grub "please s/recovery/single-user/ in generated menu.lst" [Wishlist,Closed] http://bugs.debian.org/370110

Uploaded, in the queue for post-RC

Changed in grub:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers