Ubuntu

Grub install fails on intel macs.

Reported by Jordan on 2006-09-26
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: grub-installer

Grub install fails on intel macs with Dapper and Edgy knot 3. It works however in gentoo using these directions http://gentoo-wiki.com/HARDWARE_Apple_MacBook#Grub

Related branches

Jordan (jordanu) wrote :

Since this still has the 'Unconfirmed' status I would like to add that this problem is well documented in every tutorial for Dual booting Ubuntu and OS X on intel macs ( why there hasn't been a bug report before this I don't know )

From: http://www.ubuntuforums.org/showthread.php?t=198453

"Grub installation fails at the end, just ignore it (you are going
to install lilo anyway)."

From: http://bin-false.org/?p=17

"The install will fail at the end when it tries to install GRUB"

http://desrt.mcmaster.ca/macbook.xhtml

"You need to use lilo, however as I'm told as GRUB makes an unsupported BIOS call."

The standard workaround has been either to use LILO ( or elilo although that requires kernel patches and since it does not use BIOS emulation, will not let you use some things like the proprietary ATI / Nvidia gfx drivers ). Or to use a patched version of GRUB AND delete your OS X partition and use an MBR instead of a GUID partition table ( which means, since you cannot dual boot OSX, you cannot install any firmware updates ).

These solutions were necessary for a while as patches were still being made for intel Mac compatibility but they are no longer necessary and some distributions like Fedora ( I have only heard this claim from others, I have never actually tried it myself ) install grub normally from their default installer with no extra patches or configuration needed on intel macs and Gentoo has documentation on how to use GRUB and still be able to dual boot OS X http://gentoo-wiki.com/HARDWARE_Apple_MacBook#Grub but I have not seen any such guides for Ubuntu.

IMHO this is fairly urgent as it prevents many mac users from installing Ubuntu.

Jordan (jordanu) wrote :

I tried reformatting my entire drive and using an MBR instead of a GUID partition table and although there were no errors when running the installer, the mac did not recognize the partition as being bootable so I still cannot boot Ubuntu from the hard drive.

Daniel T Chen (crimsun) on 2006-10-05
Changed in grub-installer:
status: Unconfirmed → Confirmed
pirast (pirast) wrote :

Sadly I do not have a Mac but you may want to try the solution based on BootCamp in the Fedora Wiki:

http://fedoraproject.org/wiki/FedoraOnMactel

Jordan (jordanu) wrote :

I have found instructions for installing GRUB on Ubuntu here and they have worked for me on a macbook and a macbook pro and should work on any other intel mac: https://help.ubuntu.com/community/MacBook

blahyugi (blahyugi) wrote :

Just fyi. Two months ago I took my intel based Mac Mini, converted the hdd to MBR mode and put in Edgy installation CD. All I had to do was to click forward, everything worked. Including the grub installation (to mbr) and booting up. The installation was flawless all the way.

Hey, thanks for the info. I need to have dual boot in my MB Pro, would
converting to MBR destroy this capability? How do you convert to MBR?

Paul

--
"Trouble rather the tiger in his lair than the sage amongst his books for to
you kingdoms and their armies are mighty and enduring, but to him they are
but toys of the moment to be overturned by the flicking of a finger."

Gordon R. Dickson

> From: blahyugi <email address hidden>
> Reply-To: Bug 62386 <email address hidden>
> Date: Tue, 26 Dec 2006 22:03:58 +0000
> To: <email address hidden>
> Subject: [Bug 62386] Re: Grub install fails on intel macs.
>
> Just fyi. Two months ago I took my intel based Mac Mini, converted the
> hdd to MBR mode and put in Edgy installation CD. All I had to do was to
> click forward, everything worked. Including the grub installation (to
> mbr) and booting up. The installation was flawless all the way.
>
> --
> Grub install fails on intel macs.
> https://launchpad.net/bugs/62386

Jordan (jordanu) wrote :

Yes, converting to MBR will prevent you from being able to boot OSx on the
same hard drive but luckily converting to MBR is not required, for grub ( I
dislike lilo ) you can follow this guide http://wiki.ubuntu.com/MacBook ( it
is for a macbook but all of the install instructions up to and including the
step " install network-manager" work on a macbook pro also ). There is also
a macbook pro wiki page which you can use to get everything else set up
after the install, or you could follow the macbook pro install instructions
also, but as I said that will install LILO instead of GRUB. ( I have
followed the macbook instructions on my mac and the intructions are actually
in no way macbook specific and will on any intel mac ) If you would like
more help feel free to email me personally :)

On 1/3/07, Paul Fieber <email address hidden> wrote:
>
> Hey, thanks for the info. I need to have dual boot in my MB Pro, would
> converting to MBR destroy this capability? How do you convert to MBR?
>
> Paul
>
> --
> "Trouble rather the tiger in his lair than the sage amongst his books for
> to
> you kingdoms and their armies are mighty and enduring, but to him they are
> but toys of the moment to be overturned by the flicking of a finger."
>
> Gordon R. Dickson
>
>
> > From: blahyugi < <email address hidden>>
> > Reply-To: Bug 62386 <email address hidden>
> > Date: Tue, 26 Dec 2006 22:03:58 +0000
> > To: < <email address hidden>>
> > Subject: [Bug 62386] Re: Grub install fails on intel macs.
> >
> > Just fyi. Two months ago I took my intel based Mac Mini, converted the
> > hdd to MBR mode and put in Edgy installation CD. All I had to do was to
> > click forward, everything worked. Including the grub installation (to
> > mbr) and booting up. The installation was flawless all the way.
> >
> > --
> > Grub install fails on intel macs.
> > https://launchpad.net/bugs/62386
>
> --
> Grub install fails on intel macs.
> https://launchpad.net/bugs/62386
>

Colin Watson (cjwatson) wrote :

This should eliminate the need to convert to MBR. d-i works for me on an Intel Mac now.

grub (0.97-20ubuntu3) feisty; urgency=low

  * Add GPT patch from
    http://lists.gnu.org/archive/html/bug-grub/2006-07/msg00037.html, to
    simplify support for Intel Macs (LP: #62386).

 -- Colin Watson <email address hidden> Fri, 19 Jan 2007 10:42:32 +0000

Changed in grub:
assignee: nobody → kamion
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers