menu.lst has change after the updates (removes Windows option)

Bug #61793 reported by c on 2006-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

after the update, the menu.list added new entries

title Ubuntu, kernel 2.6.15-27-386
root (hd0,4)
kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/hda5 ro quiet splash
initrd /boot/initrd.img-2.6.15-27-386
savedefault
boot

title Ubuntu, kernel 2.6.15-27-386 (recovery mode)
root (hd0,4)
kernel /boot/vmlinuz-2.6.15-27-386 root=/dev/hda5 ro single
initrd /boot/initrd.img-2.6.15-27-386
boot

but upon doing that it also removed the entries for Windows. I would consider this a bug because if you're a windows user and you would like to try ubuntu then this will make me feel as if you have deleted my windows partition.

Caroline Ford (secretlondon) wrote :

It didn't do this to me - alarmingly it made my windows partition my default boot!

 status Rejected

It only does that if you manually moved the windows partition inside the
DEBIAN AUTOMAGIC KERNEL LIST

Changed in grub:
status: Unconfirmed → Rejected
mwacker (mew66) wrote :

I'd like to confirm this, too. What I did is manually edit menu.lst to move Windows Vista/Longhorn to the top and rename it Windows 7. Now Ubuntu always wants to remove the Windows option when it updates the kernel!

"This is not a bug, it's a feature!" jokes aside for those who don't like Windows, this definitely should be fixed. Adding an updated kernel should never remove entries from menu.lst (unless perhaps you wanted to remove entries to older versions of the kernel in the future). It never happened before I updated menu.lst, and it shouldn't happen now.

Changed in grub (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) wrote :

This is never going to be fixed in grub. If you want Windows to be the first boot option with grub 1, put it *above* the line marked "### BEGIN AUTOMAGIC KERNELS LIST".

The problems with the grub config file are fundamental, and are only fixed with the migration to grub2 (in progress).

Changed in grub (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers