grub is not installed to secondary RAID1 disk

Bug #58894 reported by Timothy Miller on 2006-09-04
8
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Jonathan Rascher

Bug Description

I have two identical drives that I have configured as RAID1. I set up software RAID1 on them and installed Dapper.

After installing, I shut down and pulled the power connector from the secondary disk. I booted up, and all was fine. [I will file another bug report related to this.]

I shut down, and connected power only to the secondary drive. When I powered up, it would not boot. I tried fiddling with IDE cables and BIOS settings. Nothing.

One possibility is that grub was not installed on the secondary drive.

Another possibility is that the installer lied and really only set up one disk on the RAID1 array. I don't know how to tell which.

Either way, this is a massively serious problem, because if the primary drive fails, the user is left with no way to boot the secondary and recover their data.

Timothy Miller (theosib) wrote :

Note: I installed gkrellm (a system monitoring tool), and I have been able to verify that both drives are indeed being used. So it must be a GRUB problem.

Timothy Miller (theosib) wrote :

Additionally, I can confirm that it is an installation issue where the installer did not properly install GRUB on the secondary drive. I did some research and figured out how to set it up manually. Now it will boot from the secondary drive.

At the very minimum, the installer should warn the user that their secondary drive isn't going to have grub installed on it right and that they need to do it manually.

Tormod Volden (tormodvolden) wrote :

The installer doesn't even try to install grub to both devices. Consider it luck that it was able to install to one of the devices successfully :)

Changed in grub:
status: Unconfirmed → Confirmed
Dustin Kirkland  (kirkland) wrote :

Hello-

Thanks for the report. I did quite a bit of work in Intrepid trying to fix a swath of RAID issues in Ubuntu.

I modified both grub (runtime), and grub-installer (installer) to install to each disk in a RAID device providing /boot or /.

I marked those changelogs against Bug #33649 and Bug #264160.

I'm going to mark this bug as "Fix Released".

If it would be possible, please test against Intrepid and reopen here if the new behavior is not as expected.

Thanks!
:-Dustin

Changed in grub:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers