grub-common conflicts with grub-doc

Bug #526180 reported by Daniel Gnoutcheff on 2010-02-23
This bug report is a duplicate of:  Bug #493968: Can not install grub-doc. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

Package grub suggests grub-doc, but it also depends on grub-common, which refuses to allow grub-doc to install. In the dependencies of grub-common, I see this:
Conflicts: grub-doc (<< 0.97-32)
However, the latest version of grub-doc is 0.97-29ubuntu59, which apparently isn't new enough.

Ubuntu: 9.10
grub: 0.97-29ubuntu59
grub-common: 1.97~beta4-1ubuntu4.1
grub-doc (that I'm trying to install): 0.97-29ubuntu59

Jane Atkinson (irihapeti) wrote :

I've noticed the same thing. I'm wanting to install grub in Lucid, because grub2 is too enthusiastic about installing to the MBR when I've already got another Ubuntu install in another partition which uses grub. But when I install grub into Lucid, I still end up with grub2 because of this dependency.

I don't see why grub has grub-common as a dependency. It doesn't in Hardy, and yes, grub2 is an option even in the Hardy repositories.

Colin Watson (cjwatson) wrote :

This is also bug 493968, since fixed.

@Irihapeti: grub depends on grub-common because it now uses grub-probe from there; it didn't before. grub-common is not all of grub2, though. Furthermore, grub2 in Lucid should be pretty clear about offering you the option of where to install, and should let you say "nowhere" and confirm that you mean it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers