system update fails and add many entries in menu.lst file

Bug #520708 reported by Frederic Revelant on 2010-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

According to a message in the system trays, i accepted to update the system. I entered the root passwd, ... all was going well.
In the middle of the process, a dialog proposed to me many choices about menu.lst file (merge, compare, keep version of package author, ...). I didn't really understand what did it mean. I think that my choice was compare, but i not really remember what i'd select. The installation process go further and again the same dialog with the same question !!!
Same answer, process go further and again the question. This time i answer keep version of package author.
The process started again and then failed with an error message. I logged out. Reboot the system and at the grub menu, i saw many new pairs of entries (normal and recovered mode), representing the same choice : a new kernel version. I selected the more recent one. Unbuntu started normally but when i was in my session, i saw in the system tray an icon indicating that a problem occurred in the previous installation. It seems that there is no problem and the system is ready to use but following the process after a click on the systray icon, i'm here describing a bug.

Tchuss ...

Description: Ubuntu 9.10
Release: 9.10

grub:
  Installé : 0.97-29ubuntu59
  Candidat : 0.97-29ubuntu59
 Table de version :
 *** 0.97-29ubuntu59 0
        500 http://fr.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

ProblemType: Package
Architecture: i386
Date: Thu Feb 11 22:24:50 2010
DistroRelease: Ubuntu 9.10
ErrorMessage: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
NonfreeKernelModules: nvidia
Package: linux-image-2.6.31-19-generic 2.6.31-19.56
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: grub
Title: package linux-image-2.6.31-19-generic 2.6.31-19.56 failed to install/upgrade: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Uname: Linux 2.6.31-19-generic i686

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers