GRUB splash images do not work.

Bug #51866 reported by Shade on 2006-07-04
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Unassigned

Bug Description

When I am trying to activate grub bootsplash image it doesn't show up after reboot. I tried the kubuntu-grubsplash-images (or whatever it's called). The package loads up the blue_neon bootsplash as default and it works for me, but i when I am trying to change it to something else it's either doesn't display anything or displays resized, and replaced image with a reversed colours (real_colors_01.xpm.gz). The change only takes effect when I manually edit menu.lst file. In other cases sudo update-grub command gives the following output:

Searching for GRUB installation directory ... found: /boot/grub
Testing for an existing GRUB menu.list file ... found: /boot/grub/menu.lst
Searching for splash image ... found but preserving previous setting: splashimage=(hd1,0)/boot/grub/splashimages/KUBUNTU_splashscreen_blue_neon_logo_03.xpm.gz
splashimage=(hd1,0)/boot/grub/splashimages/KUBUNTU_splashscreen_blue_neon_logo_03.xpm.gz
splashimage=(hd1,0)/boot/grub/splashimages/KUBUNTU_splashscreen_blue_neon_logo_03.xpm.gz
Found kernel: /boot/vmlinuz-2.6.15-23-k7
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Richard Johnson (nixternal) wrote :

I can confirm this, as I worked right along with Shade on IRC trying to get it work. HOwever, we even tried manually, only to get garbled screens.

Shade (adam-mrowczynski) on 2006-07-04
Changed in grub-splashimages:
assignee: nobody → adam-mrowczynski
Richard Johnson (nixternal) wrote :

Shade, only assign it to yourself if you are working on creating a patch for it. I moved it back to nobody, as this will get the developers to look at it. If you are working on a patch, then by all means, go ahead and assign yourself back to it. Thanks!!!

Changed in grub-splashimages:
assignee: adam-mrowczynski → nobody
frogzoo (frogzoo) wrote :

You should attach the image you're using.

Grub will fail to display the image correctly unless it's in the right .xpm format. ImageMagick can create the file for you.

convert -resize 640x480 -colors 14 picture.jpg ImageName.xpm

frogzoo (frogzoo) wrote :

Another thing to try would be installing package 'grub-splashimages'

If these images work, the problem's not with grub, but your image file.

Changed in grub-splashimages:
status: Confirmed → Needs Info

On Tuesday 04 July 2006 18:43, frogzoo wrote:
> Another thing to try would be installing package 'grub-splashimages'
>
> If these images work, the problem's not with grub, but your image file.
>
> ** Changed in: grub-splashimages (Ubuntu)
> Status: Confirmed => Needs Info
We tried both, grub-splashimages and kubuntu-grub-splashimages. Neither one
worked the way they should. We followed multiple howtos concerning the grub
splashimages to no avail. I will work on trying the imagemagik trick, however
one shouldn't have to do that in order to get these to work.
--
Rich Johnson (nixternal)
https://wiki.ubuntu.com/nixternal
https://launchpad.net/people/nixternal
"The best thing about democracy is that it gives every voter a chance to do
something stupid."

Note: Grub expects the filename in the format .xpm.gz

Once you have your .xpm file (from ImageMagick), gzip it.

Lastly, make sure your grub path to the file is correct. From the grub prompt, you can actually browse & display the file images.
>root (hd0,6)
>splashimage /boot/grub/myfile.xpm.gz

Once you establish grub can find & display the file, you update menu.lst.
You need something like:

# Splash Image
splashimage (hd0,6)/boot/grub/myfile.xpm.gz

Then 'sudo update-grub' & reboot.

frogzoo (frogzoo) wrote :

No update in a week. Assuming this issue is resolved.

If this isn't the case, please feel free to modify bug status.

Changed in grub-splashimages:
status: Needs Info → Rejected
Richard Johnson (nixternal) wrote :

1 week is hardly enough time, go after the 6 month and greater issues please. This is a valid issue. Also note that the images are in the .xpm.gz format. You shouldn't have to do anytype of work around for these, and there should be an easier way for a user to set these up.

Changed in grub-splashimages:
status: Rejected → Confirmed
Shade (adam-mrowczynski) wrote :

Well if anyone cares actually :)... I'd like to mention, that this is still an issue in Feisty Fawn release of Kubuntu. I've checked it just recently and it causes exactly the same problems it does before

Matti Lindell (mlind) wrote :

Does it work for you if remove the splashimage lines from /boot/grub/menu.lst, symlink desired splashimage as /boot/grub/splash.xpm.gz and invoke update-grub ?
If you have a separate /boot partition, then the splashimage must be on the same partition.

Matti Lindell (mlind) wrote :

Is this still an issue in Hardy ?

Changed in grub-splashimages:
status: Confirmed → Incomplete
Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in grub-splashimages:
status: Incomplete → Invalid
Adrian Godoy (adrigodoy) wrote :

Issue persists in Hardy.

Changed in grub-splashimages:
status: Invalid → New
Adrian Godoy (adrigodoy) wrote :

Issue persists in Hardy. Package involved: grub-splashimages.
1. I renamed one of the files to splash.xpm.gz
2. Moved the file to /boot
3. Ran update-grub:
root@zebra:/boot# update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... found but preserving previous setting: splashimage=(hd0,0)/boot/splash.xpm.gz
Found kernel: /vmlinuz-2.6.24-19-generic
Found kernel: /memtest86+.bin
Updating /boot/grub/menu.lst ... done
root@zebra:/boot#

That is pretty much where I am at. I tried to display the images under the grub prompt as indicated a couple comments ago. It seems like my version of grub does not have splashimage in it because after I mount the partition with the command root (hd0,0) and try to enter the splashimage command I get an error 27.

grub> root (hd0,0)
root (hd0,0)
grub> splashimage /boot/splash.xpm.gz
splashimage /boot/splash.xpm.gz

Error 27: Unrecognized command
grub>

I tried placing the file in /boot/grub with the same results.

Let me know if you need extra information.

Schelfhout (schelf404) wrote :

Workaround is to install KGrubEditor or QGRUBEditor.
Then set the image you want through the software.
Result: the image is displayed.

I have tried via the grub shell (see comment above mine)
Same results,no splashimage in grub

Also tried:
$cd /boot/grub
$sudo ln -s splashimages/debsplash.xpm.gz splash.xpm.gz
$sudo update-grub

update-grub does find a splashimage and asks if it should replace menu.lst
After replacing the file there is a splashimage entry in menu.lst
However the image is not shown, I get a normal text-mode menu.
Tried on a virtual machine with Hardy and an MSI Wind with Interpid, Grub version 0.97.
Used the same image, debsplash.xpm.gz, for all steps.

Schelfhout (schelf404) on 2008-12-04
Changed in grub-splashimages:
status: New → Confirmed
Schelfhout (schelf404) wrote :

I did some further testing and update-grub seems the culprit.
It looks for a splashimage in /boot/grub, which needs to be named splash.xpm.gz.
Although it writes it to menu.lst it does this in the wrong format so the image is not shown.

Entry in menu.lst after running KDEGrubEditor:
splashimage=(hd0,2)/boot/grub/splash.xpm.gz

Entry in menu.lst after running update-grub:
splashimage=c5c42e26-e84a-4c1e-88b9-144ef7043362/boot/grub/splash.xpm.gz

After manually editing the update-grub entry to splashimage=(hd0,2)/boot/grub/splash.xpm.gz the image is shown.

So nothing wrong with the package grub-images, so changed package to grub.

Connor Imes (ckimes) on 2008-12-17
Changed in grub:
importance: Undecided → Medium
wayward4now (wayward4now) wrote :

In Kubuntu Karmic-testing i686 I do not have a file named menu.lst I do have a pile of menu.list.new.* files. I do not have a splash.xpm.gz file in /boot/grub but I do have a directory /boot/grub/splashimages. But that file is not there either, although there are about 10 files to do with splashimages relating to KDE. I'd like to see this one fixed. Thanks! Ric

electhor (electhor) wrote :

I have fixed this issue with the help of drs305 from ubuntu forums.
It seems that somewhere along the way, when /boot/grub/grub.cfg was altered to the 'new' format where one only has to add a line to "WALLPAPER=...", the file somehow corrupted and half of it was missing and it looked as though the /etc/grub.d/05_debian_theme section of /boot/grub/grub.cfg was a mix of the original file and the 'new' file syntax. Essentially had no choice but to get a copy of drs305 /boot/grub/grub.cfg and then add/edit the image I wanted. It now works fine.
I am not a programmer, but there seems to be a corruption of /etc/grub.d/05_debian_theme section between the 'old' and 'new' voodoo code pertaining to that part of /boot/grub/grub.cfg. From memory, when the original grub upgrade was introduced I chose to keep current format (or whatever the exact text is), this is when this problem/corruption occurred as the splash-image had worked fine until that point. Since fixing it with a copy of a 'good' /boot/grub/grub.cfg (from drs305) I have since chosen to use the 'maintainers version' and everything has worked correctly. Not sure if the above is relevant, but that is the series of events that occurred in my case, when the grub splash-image not loading arose.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers