Ubuntu

kernel 2.6.31-12-generic renders "Error 13: Invalid or unsupported executable format"

Reported by mobrien118 on 2009-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub

I'm not sure if this is a grub error, kernel error or ext4 error.

I recently ran apt-get upgrade on karmic and ended up with the grub error "Error 13: Invalid or unsupported executable format" after installing kernel 2.6.31-12-generic. If I select 2.6.31-11-generic (the previous kernel) it works without a problem.

Right before I ran this upgrade, I upgraded the hard disk to ext4 using the procedure linked to from the Karmic beta information page. The system was a fully patched (up to 10/7/09 package lists) system.

So, to reproduce, one should be able to:

1. Change /etc/fstab to ext4 for main HD.
2. Use tune2fs (not sure correct command name) to upgrade the FS to ext4 and use fsck to repair it.
3. Install 2.6.31-12-generic kernel packages.
4. Try to boot into 2.6.31-12-generic kernel.

Also, I installed grub2 in chain-loading mode. The same error results when GRUB2 is used to boot the same kernel, as well as using GRUB1.5 to select the kernel.

Hope this information helps squash this bug!

ProblemType: Bug
Architecture: i386
Date: Fri Oct 9 10:17:22 2009
DistroRelease: Ubuntu 9.10
Package: grub (not installed)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: grub
Uname: Linux 2.6.31-11-generic i686
XsessionErrors:
 (gnome-settings-daemon:1761): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1761): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1796): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1816): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1784): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.2/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

I had the same issue, upgraded from ext3 to ext4 via livecd, booted everything was fine, had to reboot, received a:

24 : Attempt to access block outside partition

Installed grub2 in chain load to see if that would fix, started getting

13 : Invalid or unsupported executable format

Ended up finding this nugget of wisdom on launchpad

grub-install --recheck /dev/sda

Which fixed it.

Here is another person with the same problem, though he seems to have gone through a lot more steps

http://mapopa.blogspot.com/2009/01/grub-voodoo-error-no-1324-and-how-do-i.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers