Intrepid: Ubuntu Alternate grub install fails

Bug #256989 reported by Dave Morley on 2008-08-11
4
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
High
Martin Pitt
Intrepid
High
Martin Pitt

Bug Description

RELEASE: Intrepid
CD/DVD VARIANT: Ubuntu 32bit Alternative CD
ISO BUILD: 20080811

SYMPTOMS: Grub fails to install and configure.

CAUSE: Unknown

STEPS TO REPRODUCE:
1/ burn cd
2/ install it.

Tested on 2 different sets of hardware.

Related branches

Dave Morley (davmor2) wrote :
Dustin Kirkland  (kirkland) wrote :

As a point of contrast, I was *not* able to reproduce this problem on the 20080811 build of the amd64 Ubuntu Server in a KVM.

:-Dustin

Martin Pitt (pitti) wrote :

Confirming on current alternate. chrooting into /target and apt-get -f install works fine, though.

Changed in grub:
milestone: none → intrepid-alpha-4
Martin Pitt (pitti) wrote :

I think I got it: grub.postinst calls "/usr/sbin/kernel-helper -i", which in turn calls update-grub at the end. I -x'ed the script and dropped the >/dev/null, to see the grub error messages. It fails because /boot/grub does not exist yet. Apparently d-i installs grub first, and then calls install-grub, and calls update-grub later.

Therefore a solution which fixes the installation is to only call update-grub if /boot/grub exists. This might not be the correct conceptual solution, though; Ben, can you comment whether this should work differently?

I'm going to apply that change now to get working CDs for Alpha-4.

Changed in grub:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

For the record, this is the applied patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub - 0.97-29ubuntu34

---------------
grub (0.97-29ubuntu34) intrepid; urgency=low

  * debian/kernel-helper: Do not run update-grub at the end if /boot/grub/
    does not exist, since that will make the entire script and thus package
    configuration fail. d-i installs grub and calls update-grub later.
    (LP: #256989)

 -- Martin Pitt <email address hidden> Sun, 11 May 2008 12:08:37 +0200

Changed in grub:
status: In Progress → Fix Released
Ben Collins (ben-collins) wrote :

Martin, that sounds like the right solution. If /boot/grub doesn't exist, then no need to update the boot menu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Bug attachments