GRUB bootloader error 17

Bug #24303 reported by Mark Olson on 2005-10-20
8
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Tollef Fog Heen

Bug Description

Installed Ubuntu linux 5.10 for i386 on IBM thinkpad R40. At end of
install, GRUB identified Windows XP Pro as other OS present and
asked if I wanted in install the Grub bootloader on the boot
sector. When I rebooted the system I received a "GRUB 1.5 error 17"
message and everything stopped.

Serious error since I couldn't get either OS to boot and I ended up
deleting both OS's, formatting the harddrive and reinstalling
windows XP pro.

Dennis Kaarsemaker (dennis) wrote :

On what kind of partition did you install /boot?

David (darthur) wrote :

(In reply to comment #1)
> On what kind of partition did you install /boot?

Hi,
I have had exactly the same experience. I tried to install Breezy and when the
first reboot occured error 17 with the Grub loader. I then tried to install to a
floppy disk. The loader did not get beyond the Grub start message before my
computer stopped responding.

Here is some more information about my system.
Motherboard : Gigabyte - K8NS Pro
Memory : 1GB
Processor chip : AMD Sempron 2600+
(Has a AMD 64 label stuck to the front of the box but I am sure the Semprons are
not 64 bit)
IDE Control chip type : NVidia (nForce 3)
IDE & SATA : both RAID enabled
hda : 10.2 GB Fujitsu MPC3102AT (where the boot record was written)
hdb : 120.0 GB WDC WD1200BB-00GUA (where Breezy was installed)

I also tried to use LILO but it simply displayed lots of 99 on the screen then
stopped responding.

If there is any more information you would like let me know.
I was a little surprised this happened and a bit disapointed.

David

DEFHol (dfleener) wrote :

(In reply to comment #1)
> On what kind of partition did you install /boot?

I'v received the same error. I installed Breezy on my second hard drive, and Grub on the
same drive, because I've never installed any version of Ubuntu or any Linux on my Windows
XP machine, and I didn't want to take the chance of messing something up. I formatted the
hard drive before installing and Grub is on the Master Boot Record. When I try to boot, it
says 'Filesystem type unknown, partition type 0x7' and some other install jargon. Below
that is 'Error 17: Cannot mount selected partition' I have to restart my computer to get
it to even load Windows XP. Grub lists it as another OS, But won't load it.

Chuck Short (zulcss) wrote :

This error is returned if the requested partition exists but grub cant determine what kind of partition it is. Please check you grub settings especially your root(x,y) settings. If you are trying to boot make sure your grub.conf has chainloader +1. Similar to the following:

title Microsoft Windows XP Professional
root (hdX,Y)
savedefault
makeactive
chainloader +1

where X be your your hard drive controller, and Y be your partition.

Changed in grub:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.