Error 6: Mismatched or corrupt version of stage1/stage2

Bug #21957 reported by Björn Tillenius on 2005-09-18
10
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Unassigned

Bug Description

I tried to install breezy using the netboot image. It went until a bootloader
would be installed, then grub failed with the following error:

grub> root (hd0,0)
 Filesystem type is reiserfs, partition type 0x83
grub> setup --stage2=/boot/grub/stage2 --prefix=/boot/grub (hd0,0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/reiserfs_stage1_5" exists... yes
 Running "embed /boot/grub/reiserfs_stage1_5 (hd0,0)"... 19 sectors are
embedded.
succeeded
 Running "install --stage2=/boot/grub/stage2 /boot/grub/stage1 (hd0,0) (hd0,0)
1+19 p (hd0,0)/boot/grub/stage2 /boot/grub/menu.lst"... failed

Error 6: Mismatched or corrupt version of stage1/stage2
grub> quit

Jeff Bailey (jbailey) wrote :

Is this during the install, or is this something you were doing by hand afterwards?

Björn Tillenius (bjornt) wrote :

No, this is during the install. I tried to use lilo instead, but it failed as well. See bug #13851 for the error messages I
got from running lilo.

Tollef Fog Heen (tfheen) on 2007-03-30
Changed in grub:
assignee: tfheen → nobody

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in grub:
status: New → Incomplete
Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in grub:
status: Incomplete → Invalid
Colin Watson (cjwatson) wrote :

Thanks for your report. We eventually nailed this down as bug 185878.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.