grub-reboot segfaults on read-only /boot partition

Bug #194582 reported by Rolf Leggewie on 2008-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Rolf Leggewie

Bug Description

Binary package hint: grub

I have my /boot partition mounted read-only. Trying to use grub-reboot in this situation results in the program segfaulting.

$ sudo grub-reboot 1
[sudo] password for leggewie:
Searching for GRUB installation directory ... found: /boot/grub
Probing devices to guess BIOS drives. This may take a long time.

       [ Minimal BASH-like line editing is supported. For
         the first word, TAB lists possible command
         completions. Anywhere else TAB lists the possible
         completions of a device/filename. ]
grub> savedefault --once --default=1
/usr/sbin/grub-reboot: line 68: 6599 Segmentation fault (core dumped) grub --batch --config-file=$config_file $@ <<EOT
savedefault --once --default=$default
quit
EOT

The command worked fine after I remounted /boot read-write.

Rolf Leggewie (r0lf) wrote :

Still segfaults on hardy

Rolf Leggewie (r0lf) wrote :

still unchanged on hardy in version 0.97-29ubuntu21.1

Rolf Leggewie (r0lf) wrote :

karmic grub no longer segfaults. closing.

Changed in grub (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

nominating to push this fix to hardy.

Rolf Leggewie (r0lf) wrote :

unfortunately, I rejoiced too soon. The problem is still present in karmic.

Changed in grub (Ubuntu):
status: Fix Released → Triaged
Rolf Leggewie (r0lf) on 2009-12-12
Changed in grub (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers