package linux-image-3.13.0-170-generic 3.13.0-170.220 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1

Bug #1830066 reported by ORSOrama on 2019-05-22
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Undecided
Unassigned

Bug Description

After trying to update, a message error appeared

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-170-generic 3.13.0-170.220
ProcVersionSignature: Ubuntu 3.13.0-169.219-generic 3.13.11-ckt39
Uname: Linux 3.13.0-169-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.29
Architecture: amd64
Date: Wed May 22 14:13:48 2019
DuplicateSignature: package:linux-image-3.13.0-170-generic:3.13.0-170.220:run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
ErrorMessage: run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
InstallationDate: Installed on 2015-02-11 (1561 days ago)
InstallationMedia: Ubuntu-GNOME 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.8
 apt 1.0.1ubuntu2.23
SourcePackage: grub
Title: package linux-image-3.13.0-170-generic 3.13.0-170.220 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
UpgradeStatus: No upgrade log present (probably fresh install)

ORSOrama (orsorama) wrote :
tags: removed: need-duplicate-check
Steve Langasek (vorlon) wrote :

You have the grub package installed on your system, which is grub 1.x and is not the default bootloader in Ubuntu 14.04; and you have not configured the package, which means it causes kernel installation to fail at the bootloader stage.

The solution is for you to remove the grub package from your system with 'sudo apt-get remove --purge grub' as this package is not needed. You should be using the default grub-pc package instead.

Changed in grub (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers