no way to configure update-grub not to set 'quiet' option in menu.lst non-recovery stanzas

Bug #137136 reported by Peter Maydell on 2007-09-03
10
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: grub

This is grub version 0.97-29ubuntu3.

There doesn't seem to be any way to configure update-grub not to put the 'quiet' keyword into the menu.lst stanzas for any non-recovery kernel. There's no menu.lst manpage, so the only documentation seems to be in the menu.lst file itself, and there's nothing about this there. Also, the update-grub script says:

        if [ ! -n "$recovery_desc" -a x"$supports_quiet" = x"true" ]; then
                echo "quiet" >> $buffer
        fi

ie if this isn't a recovery kernel and grub supports the 'quiet' keyword then you always get it.

The quieten-grub spec (https://wiki.ubuntu.com/QuietenGrub) lists "user always wants to boot without 'quiet'" as one of its use cases, so this ought to be possible somehow...

libertyernie (libertyernie) wrote :

Change:
# defoptions=quiet splash
to
# defoptions=splash
There you go.

Peter Maydell (pmaydell) wrote :

No, that just removes 'quiet' from the kernel command line (which I've already done). The grub 'quiet' keyword controls messages from grub itself, and is something different.

Tormod Volden (tormodvolden) wrote :

I think the use case in the wiki is about the boot/kernel option, not the grub option. Therefore this is not really a bug. If you want to disable the grub "quiet" option, add
"supports_quiet=false" to your /etc/default/grub

Changed in grub:
status: New → Invalid
ChrisKelley (ckelley) wrote :

Hi Tormod, thanks for your answer, as I always re-edited menu.lst to remove the quiet lines which update-grub always wrote. None of my ubuntu distributions have a /etc/default/grub file; do you mean we create that file with the line supports_quiet=false ? imho, this should be the default, as the menu.lst already has quiet splash set as options. I believe the normal user would believe when they remove quiet that it should stay removed.
:) Chris

Tormod Volden (tormodvolden) wrote :

Yes, you can create /etc/default/grub yourself, it's not there by default. "quiet splash" are kernel/boot parameters, not grub options. It's a bit confusing but those two "quiet" are two different things.

Peter Maydell (pmaydell) wrote :

I note that (a) /etc/default/grub isn't documented in the update-grub(8) manpage; (b) there's no indication that this supports_quiet setting is supposed to be a user setting rather than a random internal script variable that might stop working or behave differently in future (c) there's no way to have some kernels have the grub 'quiet' setting but not others using this workaround.

I don't think I agree with your reading of the use case either. The text of that page up to the use case bits is talking generally about all messages printed before the usplash kicks in, and to the extent that it distinguishes between grub's 'quiet' and the kernel's quiet, it's talking about the former, not the latter.

So I disagree with this bug being closed as 'invalid'.

Matt T. Proud (matttproud) wrote :

I agree entirely with Peter on this. By not including a skeleton /etc/default/grub or not mentioning the file in the standard documentation, you guys are strongly breaking the principle of least surprise.

To date, I think this is the only case of a program I have encountered on a Debian-based system that can use something under /etc/default/${PROGRAM} without having it be documented nor having a skeleton file.

Attached is a debdiff patch.

Tormod Volden (tormodvolden) wrote :

Thanks for the patch. I think this bug should be set to "wishlist", but I can't :)

Changed in grub:
status: Invalid → Confirmed

No matter the steps I take, I cannot un-quiet my Gusty install. One of
the first things I do (after fixing apt's sources.list) is to undo the
splash and quiet. I've done it all and can't get it to show the
startup like it did with fiesty. I don't know if Gutsy does this to
our servers (as opposed to Fiesty) as the first apt-get they receive
is ssh so I can go back to my desk.

Once I get caught up with work, I'll research how to create a bug
since even with the "fixed steps" I cannot undo this "feature".
Basically, I consider forcing quiet and blanking the screen akin to
some of the dumbing down microsoft does to protect people from seeing
how things work.

:) Chris

--
Chris Kelley
President
California Cycleworks, Inc
www.ca-cycleworks.com
619/501-2466

On 1/1/08, Tormod Volden <email address hidden> wrote:
> Thanks for the patch. I think this bug should be set to "wishlist", but
> I can't :)

Steve Langasek (vorlon) on 2008-01-28
Changed in grub:
importance: Undecided → Wishlist
ChrisKelley (ckelley) wrote :

On 1/28/08, Steve Langasek <email address hidden> wrote:
> ** Changed in: grub (Ubuntu)
> Importance: Undecided => Wishlist

I pose that until a person can make the console display on boot, this
isn't a wishlist. This bug is problem enough that I would task time to
try a different linux. I thought my laptop had locked up as the screen
just stayed blank on start up. No, turns out fsck was running. Until I
removed the battery and rebooted and checked the log...

oops. I'm thankful there was no consequence.

Best,
Chris

--
Chris Kelley
www.ca-cycleworks.com

Tormod Volden (tormodvolden) wrote :

Chris, does the grub quiet command cause your screen to stay blank? That's certainly a more serious issue, can you please file a new bug?

ChrisKelley (ckelley) wrote :

On 1/29/08, Tormod Volden <email address hidden> wrote:
> Chris, does the grub quiet command cause your screen to stay blank?
> That's certainly a more serious issue, can you please file a new bug?

Hi Tormod,

Thanks for writing back. No, the problem I have is that I am unable to
disable the quiet option. It is always quiet during boot. This
"feature" is unique to my Dell D630 Intel laptop.

Every other ubuntu install I have configured to watch the console as
the computer boots up. I have 6 ubuntu computers:
Dell D630 notebook Intel core-duo with ICH8 family chipset: Kubuntu Gutsy x86_64
Sony vaio sz220 notebook intel duo-core ICH7 chipset: Xubuntu Gutsy
Dell C521 dimension desktop #1 AMD athlon 64 edubuntu lts dapper
Dell C521 dimension desktop #2 AMD athlon 64 ubuntu server gutsy
Dell C521 dimension desktop #3 AMD athlon 64 ubuntu server gutsy
hp e-pc Pentium 4 Xubuntu gutsy

It would not irritate me so much if it wasn't the computer I spend the
most time on. And it is this one I spend the most time watching it
boot ... with nothing to show for its progress. My LTS server:
$ uptime
 03:29:43 up 110 days

And I only rebooted because I noticed the kernel version had changed a
number of times since the last reboot. :)

Thanks,
Chris

--
Chris Kelley
www.ca-cycleworks.com

Tormod Volden (tormodvolden) wrote :

The grub "quiet" option (or command if you like) - the one that is on its own line inside a menu entry stanza - only disables some messages that grub prints before the kernel boots. It does not alter the verbosity of the kernel nor of the start-up scripts. Unless there's a bug. See the Ubuntu grub source debian/patches/quiet.diff for more information.

Just for comparison: the kernel "quiet" option (or parameter) - the one that is on the kernel line - tells the kernel to be less verbose, and is also probed for by the start-up scripts (see /usr/share/initramfs-tools/init and /usr/share/initramfs-tools/scripts/init-top/usplash and /etc/init.d/rc). This bug report is not about this one.

ChrisKelley (ckelley) wrote :

Hi Tormod,

Thanks for writing back. Ah, yes. I understand better now. Then my
humble suggestion would be to mention /etc/default/grub and the
supports_quiet=false option within the comments of menu.lst (the
magically reappearing quiet grub option is what brought my annoying
self here) :) That would satisfy this software engineer, recently
converted to linux.

Thanks and I go away now (happily) :)
Chris

On 1/29/08, Tormod Volden <email address hidden> wrote:
> The grub "quiet" option (or command if you like) - the one that is on
> its own line inside a menu entry stanza - only disables some messages
> that grub prints before the kernel boots. It does not alter the
> verbosity of the kernel nor of the start-up scripts. Unless there's a
> bug. See the Ubuntu grub source debian/patches/quiet.diff for more
> information.
>
> Just for comparison: the kernel "quiet" option (or parameter) - the one
> that is on the kernel line - tells the kernel to be less verbose, and is
> also probed for by the start-up scripts (see /usr/share/initramfs-
> tools/init and /usr/share/initramfs-tools/scripts/init-top/usplash and
> /etc/init.d/rc). This bug report is not about this one.
>
> --
> no way to configure update-grub not to set 'quiet' option in menu.lst non-recovery stanzas
> https://bugs.launchpad.net/bugs/137136
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers