grub-install fails to alternate SATA *and* floppy, but grub image *does* work

Bug #13435 reported by Toni Harbaugh-Blackford on 2005-03-02
6
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
High
Colin Watson

Bug Description

This problem refers to hoary array-3 amd64 installer.

I have an amd64 system with the following configuration

Asus A8N SLI Deluxe motherboard
XFX Geforce 6600 graphics card
Two SATA hard drives, with Windows XP installed on the *first*
*NO* IDE hard drives
IDE cdrom and separate burner

I installed hoary array-3 on my alternate hard drive, and everything went
fine except that the grub-install failed. No matter where grub is 'installed',
the system continues to boot Windows XP.

In order to make sure the ubuntu-generated menu.lst was ok, I created a grub
'image' floppy by cat'ing stage1 and stage2 together, then dd'ing the result
directly to /dev/fd0. I then booted the floppy, which put me directly into
grub, where I then typed in the values from menu.lst by hand and booted.
My ubuntu installation worked just fine!

I tried creating a bootable floppy with all the items from /boot/grub,
but grub segfaults on the 'setup (fd0)' command.

I can still use my ubuntu installation, but the only way to boot it
is to boot into grub first via the image floppy, then type the necessary
items by hand.

Thanks,
Toni

Colin Watson (cjwatson) wrote :

The version of grub in Array CD 3 is known to be broken on amd64, due to an
issue with it requiring an executable stack and not flagging it properly, which
recent kernels prohibit. Please try Array CD 5, which has this problem fixed,
and reopen the bug if you still experience this problem.

yes, I tested the current hoary-install-amd64.iso from 3/2/05, and
grub-install does work, for both the HD and floppy.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.