Computer reboots after selecting Vista in Grub

Bug #125507 reported by Jay Modi on 2007-07-12
4
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: grub

This seems to be a bug with both Ubuntu 7.04 and Gusty Gibbon. I am trying to dual boot Vista and Ubuntu. I installed Vista Enterprise Edition first. I gave 100 gigabytes of a 200GB drive to Vista. I then installed Ubuntu. I created a 2gb Swap partition as the 2nd partition and the rest of the space was the Ubuntu root partition. Now Grub installed to the MBR and Ubuntu will boot fine. However when I select Vista, the computer just reboots.

System specifications:
Pentium D 805
1GB DDR2-800
Abit AB9 Pro
Nvidia Quadro
Adaptec Videoh DVD Media Center Edition
LSI Logic Megaraid i4 (3x250GB drives in RAID 5)
1 200GB hard drive connected to the onboard Intel ICH8R SATA ports in IDE mode(for o/s)

I had originally tried and had the same result installing it on the raid. So I tried with a single drive and still have the issue.

Workaround for me:
I reinstalled the Vista bootloader to the MBR, and then place grub on the Ubuntu partition and now use the Vista bootloader. This functions correctly so I believe there is some issue with Grub.

I am not at my computer so I will post the menu.lst file later, but the Vista entry looks like this:
title "Windows Vista"
root (hd0,0)
makeactive
chainloader +1

The ubuntu entries also use hd0, however this is very odd because they drive shows up as sda, so shouldnt this be sd? However when I change it to this I get a partition not found error.

Jay Modi (jaymode) wrote :

Ok so I have done some more research and this definitely seems to be an issue with Grub and my motherboard/chipset. Other users of my motherboard are having the same issue with Grub and have resorted to using another bootloader called GAG to get it to work. Please see this discussion:
http://forum.uabit.com/showthread.php?t=125859

Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in grub:
assignee: nobody → chrisccoulson
status: New → Incomplete
Jay Modi (jaymode) wrote :

Yes this is still an issue for me. I am currently running 8.04 and now Windows XP instead of Vista. However, the same issue still exists and my solution to solve this problem has been to use the Windows bootloader in addition to Grub. So first my computer will go to the Windows XP bootloader and then to grub. My computer setup has changed a little bit but the motherboard is the same I believe that is where the incompatibility lies.

Chris Coulson (chrisccoulson) wrote :

Jay,

As this appears to be a problem specific to your motherboard, could you provide a more detailed description of your hardware. To do this, please provide the output of the following as separate attachments (please don't zip or rar the files):

1) lspci -vvnn
2) sudo dmidecode
3) dmesg

Could you also please attach your /boot/grub/menu.lst?

Thanks in advance

Changed in grub:
importance: Undecided → Low
Jay Modi (jaymode) wrote :

Chris,

Here are the items you have requested. First lspci output.

Jay Modi (jaymode) wrote :

dmidecode output

Jay Modi (jaymode) wrote :

dmesg output

Jay Modi (jaymode) wrote :

grub menu.lst

The windows entry is commented out. I have tried all the different combinations of switching around the hd0 and hd1 entries to no avail.

Jay Modi (jaymode) wrote :

I have provided all necessary information. If more is needed please let me know.

Changed in grub (Ubuntu):
status: Incomplete → New
Changed in grub (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody

Thank you for taking the time to report this bug and helping to make Ubuntu better. I noticed that the package version your bugging is updated in Lucid. Please update via http://releases.ubuntu.com/lucid/ repost a detailed error report, and update the bug status. Thanks!

Changed in grub (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for grub (Ubuntu) because there has been no activity for 60 days.]

Changed in grub (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers