grub installed successfully, but not loaded at boot (installed to wrong disk?)

Bug #11284 reported by Kevin Varnerin on 2004-12-19
Affects Status Importance Assigned to Milestone
grub (Ubuntu)
Colin Watson

Bug Description

I have two SATA 200 GB Maxtor drives. The first drive has XP, and I installed
the Ubuntu on the second one. When I installed Ubuntu, I said yes to install
grub on MBR. When it boots, it goes directly into XP, no grub.

During the install, it says the SATA drives are SCSI. They are SATA.

I believe the problem is Ubuntu as well as Mepis and Fedora do not support
either my motherboards (ABIT NF7-S2) SATA controller (Nvidia Raid MCP) or that
they do not support SATA hard drives.

Please help and advise.

Best Regards,

  Colin i think this is more related to grub installer than the kernel.

Please reassign it back if you believe otherwise.


Kevin Varnerin (varnerin) wrote :

The problem is defintely with GRUB. I disconnected all the hard drives in the
system except for one SATA. I installed Ubuntu without any issue. Therefore,
Ubuntu is compatible with my SATA controller. However, once I reconnected all
hard drives (two SATA - one with XP, the other Ubuntu to be installed), and
reinstalled Ubuntu, GRUB would only boot to XP.

Corey Burger (corey.burger) wrote :

Reporter, is this still an issue? If not, please close the bug.

I installed Breezy amd 64 rc on an Gigabyte Motherboard GA-K8NXP-SLI, Bios F9
I have attached 2 SATA Disks and one IDE Disk. One SATA Disk is
Boot Disk für Win XP and second partition Breezy. At the end of the installation
I saw grup writing to hd0 instead of sda (first sata disk). So on next boot
I get Win XP.

There is a serve bug in the installer telling grup to write to the wrong disk.

Best regards,


If I boot from the IDE disk grub starts and starting breezy or win xp from the
sata disk
with grub works.

So I got a working system, for now until I detach the old IDE disk.
Grup should install on the original primary boot disk (SATA)



looks like it's confirmed..

Changed in grub:
status: Unconfirmed → Confirmed
Tom Bruno (crweb) wrote :

We need to have in the installer a way to say Which drive's MBR to install too. I have serial ata drives set as my default to boot, but grub installs the ide drives by default in the ubuntu installer.

A simple fix, prompt the user at install for which drive's MBR to install to. Lots of motherboard support manual ordering of harddrive boot preference. When set to a SATA or SCSI drive, grub sees the IDE drives at the "first" drive and installs the the MBR of hda, even though hda is just a storage or swap drive, and isn't even used in booting because it's not selected as boot device in bios.

STN (sithu) wrote :

I am having the same problem. I have 60 GB Maxtor and 250 GB Western Digital both IDEs on my computer and I installed ubuntu server on Western Digital. Whenever I start my computer, it always boots into Ubuntu and I can't get into Maxtor where Windows XP Media Center is installed.

I tried disconnecting Western Digital and tried to boot into Windows (i.e only 60 GB Maxtor is attached to the system). But it says "Grub fails" or something and will not go any further. I do not know how to get my files from Windows or access any part of Windows as I can't even boot into Windows.

Any suggestion?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.