Ubuntu

Possible License Violation

Reported by mazebane@googlemail.com on 2008-07-30
8
Affects Status Importance Assigned to Milestone
grub-splashimages (Debian)
Fix Released
Undecided
Krzysztof Burghardt
grub-splashimages (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub-splashimages

I am using Kubuntu 8.04.1 and the grub-splashimages, i am using the mummy.xpm.gz file as a grub screen and then decided to use it for wallpaper and a KDE Splash screen, i then uploaded these to KDE-Look.org to share under GPL.
My first comment is that this is a license violation as the image looks like an Iron Maiden tour image as described at http://imagecache2.allposters.com/images/pic/KLN/SMV811~Iron-Maiden-Powerslave-Tour-Posters.jpg.
Sorry if this is the wrong way to go about reporting this but i was unsure what to do so started here.

Cesare Tirabassi (norsetto) wrote :

The image to which you refer is copyrighted Massimo C. Maggioni <email address hidden> and licensed with the GPL-2. Note that in the package's copyright it is clearly written:

Only images that showed good evidence of self-authorship were included in this package

I would therefore advice you to contact the copyright owner directly (it would help if you have some info about the copyright and/or license of what you think is the original image).
You may also want to talk with the current Debian maintainer: Krzysztof Burghardt <email address hidden>

Changed in grub-splashimages:
status: New → Incomplete

Thanks on the feedback.
My original post wasn't worded quite right, it should have said that the first comment posted about what i had created was to say that i had committed a licence violation.
The link in my previous post shows that the mummy very much resembles the tour poster for Iron Maiden.
I will contact the copyright owner and the package maintainer, i was unsure what to do and therefore i posted here.

Hello,

2008/7/30 <email address hidden> <email address hidden>:
> I will contact the copyright owner and the package maintainer, i was unsure what to do and therefore i posted here.

I'm maintainer of grub-splashimages. This image form Massimo C.
Maggioni was forwarded to me by previous maintainer of this package -
Luis R. Rodriguez (I adopted it). I add this image along with another
from Massimo when adopting package. Today I searched my archive and
find mail from Massimo to Luis. It looks like it is mummy from Iron
Maiden poster. Hovewer I'm not sure why Massimo put free license in
its header, this looks like derivative work.

/* XPM */

/*
* Copyright 2006 Massimo C. Maggioni <email address hidden>
*
* This xpm file image is free software; you can redistribute it and/or
* modify it under the terms of the GNU General Public License as
* published by the Free Software Foundation; either version 2
* of the License, or (at your option) any later version.
*
* This xpm file image is distributed in the hope that it will be
* useful, but WITHOUT ANY WARRANTY; without even the implied warranty
* of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
* the GNU General Public License for more details.
*
* You should have received a copy of the GNU General
* Public License along with this image; if not, write to the Free
* Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
* MA 02111-1307 USA
*/

static char * mummy_xpm[] = {

I hope he will answer and we will have a clear look at this problem.
If this image is really copyrighted (and I personally think it is) I
have to remove it from Debian package.

Thanks for pointing out this problem. Bug tracking system is, in my
opinion, the best place to report such findings.

Regards,
--
Krzysztof Burghardt <email address hidden>
http://www.burghardt.pl/

I received the following email from the image provider:

>
31/07/2008 <email address hidden>
Hello,

Is an image that I process many years ago and i don't remember that i
send to someone ... sorry.
I have this image for boot splash :-) and probably the image is
copyrighted and cannot be used, so don't distribute it.

best regards.

<

I think that clears up the problem, you will have to remove the image from the package, i have removed the image from KDE-Look.

Just my luck i publish something for the first time, check all the packages i got the images form and one of the isn't GPL in the end :(

Cesare Tirabassi (norsetto) wrote :

OK, marking this as confirmed then, we will sync the update from Debian when its ready.

Changed in grub-splashimages:
status: Incomplete → Confirmed
Krzysztof Burghardt (burghardt) wrote :

Fixed package was uploaded to mentors.d.n today. I hope my sponsor will upload it in near future.

http://mentors.debian.net/debian/pool/main/g/grub-splashimages/grub-splashimages_1.2.3.dsc

Changed in grub-splashimages:
status: New → Fix Committed
Krzysztof Burghardt (burghardt) wrote :

Version 1.2.3 is in unstable now. Ubuntu archive should synchronize with this version. Can I ask for such synchronization, or it is done automatically?

Changed in grub-splashimages:
assignee: nobody → burghardt
status: Fix Committed → Fix Released
Cesare Tirabassi (norsetto) wrote :

Please sync grub-splashimages 1.2.3 (universe) from Debian unstable (main).

Changelog since current intrepid version 1.2.2:

grub-splashimages (1.2.3) unstable; urgency=high

  * Removed mummy.xpm.gz due to copyright issues
  * "Homepage:" pseudo-header moved to regular header
  * debian/copyright file was reformated to not contain more than 80 characters
    in one line
  * "Standards-Version:" bumped to 3.8.0

 -- Krzysztof Burghardt <email address hidden> Thu, 31 Jul 2008 21:27:41 +0200

Steve Langasek (vorlon) wrote :

[Updating] grub-splashimages (1.2.2 [Ubuntu] < 1.2.3 [Debian])
 * Trying to add grub-splashimages...
  - <grub-splashimages_1.2.3.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <grub-splashimages_1.2.3.dsc: downloading from http://ftp.debian.org/debian/>
I: grub-splashimages [universe] -> grub-splashimages_1.2.2 [universe].

Changed in grub-splashimages:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers