Ubuntu

grub failed to install to /dev/sda on retry

Reported by Jean-Baptiste Lallement on 2012-04-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Medium
Unassigned

Bug Description

Precise Desktop i386 20120423

TEST CASE:
1. Start a live session from a usb stick
2. Start ubiquity
3. Select the manual partitioner
4. '/dev/sdb' (installation media) is selected by default (bug 987418) if it is not, select it (grub will fail to install at the end of the installation, this is expected and the objective of this test)
5. Continue with the installation
6. At the end of the installation grub fails to install to /dev/sdb and a prompt is displayed to select another device
7. Select '/dev/sda' and validate

EXPECTED RESULT
grubs installs to /dev/sda

ACTUAL RESULT:
This crash. On reboot the user is dropped to a grub shell

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.16
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CasperVersion: 1.315
Date: Tue Apr 24 18:22:14 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Brian Murray (brian-murray) wrote :

Apr 24 16:21:54 ubuntu ubiquity: Apr 24 18:21:54 ubiquity: Starting up '['log-output', '-t', 'ubiquity', '--pass-stdout', '/usr/share/grub-installer/grub-installer', '/target']' for ubiquity.components.grubinstaller.GrubInstaller
Apr 24 16:21:54 ubuntu grub-installer: info: architecture: i386/generic
Apr 24 16:21:54 ubuntu ubiquity: grub-probe: error: cannot find a device for / (is /dev mounted?).
Apr 24 16:21:54 ubuntu ubiquity: grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Apr 24 16:21:54 ubuntu grub-installer: info: Identified partition label for /dev/sda6: msdos
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-legacy
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-efi
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64-bin
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-efi-amd64
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32-bin
Apr 24 16:21:56 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-efi-ia32
Apr 24 16:21:57 ubuntu grub-installer: info: Installing grub on '/dev/sda'
Apr 24 16:21:57 ubuntu grub-installer: info: grub-install supports --no-floppy
Apr 24 16:21:57 ubuntu grub-installer: info: Running chroot /target grub-install --no-floppy --force "/dev/sda"
Apr 24 16:21:58 ubuntu grub-installer: /usr/sbin/grub-probe: error: cannot find a device for /boot/grub (is /dev mounted?).
Apr 24 16:21:58 ubuntu grub-installer: error: Running 'grub-install --no-floppy --force "/dev/sda"' failed.

Changed in grub-installer (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/987927

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers