Ubuntu

"executing 'grub-install /dev/sda' failed. This is a fatal error."

Reported by KrzysiekT on 2012-04-07
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

This appeared on /dev/sda and /dev/sda1
Don't know what to do. Just want to test with fresh instalation.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.4
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CasperVersion: 1.312
Date: Sat Apr 7 17:43:01 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper persistent initrd=/casper/initrd.lz splash -- BOOT_IMAGE=/casper/vmlinuz
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 LANGUAGE=pl_PL.UTF-8
 TERM=unknown
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

KrzysiekT (cytruss-xl) wrote :
summary: - "executing 'grub-install /dev/sda' failed. This in a fatqal error."
+ "executing 'grub-install /dev/sda' failed. This is a fatal error."
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Enkouyami (furyhamster) wrote :

I got this error after bug #989968 on the Linux Mint 13 Mate Desktop edition livecd.

NounouRs (sandburg) wrote :

Same error ! I'm installing Ubuntu from the 12.04.1 alternate CD.

But I have a log (using Ctrl+Alt+F4 during installation) :
grub-installer: info: Installing grub on '/dev/sda'
grub-installer: info: grub-install supports --no-floppy
grub-installer: info: Running chroot /target grub-install --no-floppy --force "/dev/sda"
grub-installer: /usr/sbin/grub-setup: warn: Your core.img is unusually large. It won't fit in the embedding area.
grub-installer: /usr/sbin/grub-setup: error: embedding is not possible, but this is required when the root device is on a RAID array or LVM volume.
grub-installer: error: Running 'grub-install --no-floppy --force "/dev/sda"' failed.

And of course, my "/" root is on an LVM volume which is on a RAID 0 partition.
And second information, I've formated (ext4) the corresponding volume of "/" but all my partitions where created a long time ago, under Ubuntu 10.10... is that possible that the space reserved at this time is now too small ?

Is it also possible to boot without grub with any Boot CD or a command line trick ? (with graphics and so on...)

Ubuntu 12.04.2 install, trying to do a software raid installation.
Worked fine under Hyper-V with 4 virtual 20GB hard disks in Raid5, with ext4 on top.
Failed with above error on a Fujitsu TX100 server (intel C202 platform) trying to install to 6 Western Digital Red 3TB hard disks in Raid6. Tried with ext4 on top, and LVM with ext4 on top.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers