Can not Install Bootloader on external drive

Bug #896490 reported by simon kantor on 2011-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

could not install on partitioned external 500G drive.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubiquity 2.8.7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CasperVersion: 1.287
Date: Sat Nov 26 00:19:20 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LANGUAGE=en_CA.UTF-8
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

simon kantor (simonkantor1) wrote :
affects: ubuntu → ubiquity (Ubuntu)

Exception during installation:
Nov 26 00:18:49 ubuntu plugininstall.py: Traceback (most recent call last):
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1641, in <module>
Nov 26 00:18:49 ubuntu plugininstall.py: install.run()
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
Nov 26 00:18:49 ubuntu plugininstall.py: func(self)
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 210, in run
Nov 26 00:18:49 ubuntu plugininstall.py: self.remove_extras()
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1404, in remove_extras
Nov 26 00:18:49 ubuntu plugininstall.py: if self.db.get('apt-setup/restricted') == 'false':
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 60, in <lambda>
Nov 26 00:18:49 ubuntu plugininstall.py: lambda *args, **kw: self.command(command, *args, **kw))
Nov 26 00:18:49 ubuntu plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 81, in command
Nov 26 00:18:49 ubuntu plugininstall.py: status = int(status)
Nov 26 00:18:49 ubuntu plugininstall.py: ValueError: invalid literal for int() with base 10: ''
Nov 26 00:18:49 ubuntu plugininstall.py:

tags: added: installer-crash
Brian Murray (brian-murray) wrote :

Nov 25 23:30:47 ubuntu grub-installer: info: grub-install supports --no-floppy
Nov 25 23:30:47 ubuntu grub-installer: info: Running chroot /target grub-install --no-floppy --force "/dev/sdc5"
Nov 25 23:30:50 ubuntu grub-installer: /usr/sbin/grub-setup: warn: Attempting to install GRUB to a partitionless disk or to a partition. This is a BAD idea..
Nov 25 23:30:50 ubuntu grub-installer: /usr/sbin/grub-setup: warn: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
Nov 25 23:30:55 ubuntu grub-installer: /usr/sbin/grub-setup: error: cannot read `/boot/grub/core.img' correctly.
Nov 25 23:30:55 ubuntu grub-installer: error: Running 'grub-install --no-floppy --force "/dev/sdc5"' failed.

affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers