oneiric fresh install to raid1 from alt amd64 CD - "grub-install /dev/sda failed"

Bug #883720 reported by Dave M on 2011-10-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Installing to two new 3TB drives (/dev/sda and /dev/sdb). sda1 & sdb1 are 1Mb and flagged as bios_grub, sda2 and sdb2 are 2992GB, flagged as RAID and assembled as RAID-1 array MD0. sda3 and sdb3 are 8GB swap. Installer works OK up to the point where it installs the GRUB boot loader to /dev/sda. Then it fails with the message "grub-install /dev/sda failed". Retry fails again. Continue without boot loader shows no more errors but system will not boot after installer has finished. Looks like grub is in /boot (when /dev/md0 is mounted as /). Not sure what to do to get GRUB installed at this point...

Dave M (davem-mich) on 2011-10-30
description: updated

I'm having similar problems (installing grub under amd64 with mdadm raid1). Two questions - are you using GPT or MBR for your partition tables, and is this system using BIOS or EFI?

Dave M (davem-mich) wrote :

i think I am using GPT. Not sure about BIOS or EFI. How can I tell?

Most of the Intel Sandy Bridge platforms use EFI; generally they will start in BIOS emulation mode unless told otherwise. If you think your platform might support EFI, try manually selecting the boot device once the CD is inserted; there should be a "(uefi) <optical drive>" option or similar if your platform supports it.

This is probably the 4th bug report I've seen about GRUB not installing to RAID, so I'm trying to eliminate the number of variables involved.

Dave M (davem-mich) wrote :

My motherboard is an Intel DG33FB. My BIOS version is DPP3510.86A.0484.2008.0805.2031.

UEFI boot was disabled in the BIOS settings so I enabled it. I no longer get the failure when GRUB installs. But the system still will not boot after the installation is complete. No error messages, just the cursor blinking in the upper left corner of the monitor.

Dave M (davem-mich) wrote :

After I re-installed with UEFI enabled I could still not boot. But I found that I could boot using the alternate CD's "boot from first hard disk" option. So it looks like maybe the install process did not write the boot tracks to either of my drives. I tried using grub-install from the command prompt after choosing "rescue a broken system". No error messages but still will not boot. I updated the BIOS to version DPP3510J.86A.0572.2009.0715.2346. I also enabled AHCI on the SATA ports. Reran "grub-install --recheck /dev/sda" and "grub-install --recheck /dev/sdb". No errors. But still can not boot from either hard drive unless I use the CD.

Dave M (davem-mich) wrote :

So I decided to see if this problem was related to the fact that I am trying to load to a RAID array or maybe it is a problem with the new 3TB drive that I am using. So I tried to do an install to a single drive (/dev/sda). Once again it installs OK (no errors reported) but will not boot from /dev/sda after the install has completed. So it looks like the problem is independent of the fact that I was installing to a RAID array. The drives I am using are Hitachi "coolspin" 3TB drives, (Model: HDS5C3030ALA630 P/N: H3D30003254S Type: DK5SAD300).

Dave M (davem-mich) on 2011-11-01
description: updated
Dave M (davem-mich) wrote :

When I booted from the alt CD and selected "boot from first hard disk" I ended up at the "grub rescue" prompt. So I rebooted again from the alt CD and selected "rescue a broken system". Ran grub-install and rebooted. Still will not boot from /dev/sda. But now it will boot /dev/sda if I first boot from the alt CD and select "boot from first hard disk".

I ran the http://sourceforge.net/projects/bootinfoscript/

Attached are the results.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed

Can you boot from CD, chroot into your system, install mdadm, then try update-grub && grub-install /dev/sda ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers