Installer crashed during configure_bootloader

Bug #762299 reported by Haw Loeung on 2011-04-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Trying to install Ubuntu 11.04 beta 2. Partition table as follows:

/dev/sda1 - EFI
/dev/sda2 - /boot (ext4)
/dev/sda3 - / (btrfs)

Haw Loeung (hloeung) wrote :
description: updated
Haw Loeung (hloeung) wrote :
exactt (giesbert) on 2011-04-20
Changed in ubiquity (Ubuntu):
status: New → Confirmed
exactt (giesbert) wrote :

don't know if it is related to the latest bios update. in any case, the final version of natty installed just fine for me...

Haw Loeung (hloeung) wrote :

For me, with UEFI disabled in the bios, the installation worked like a charm so I'm guessing it's grub + UEFI enabled that's having problems.

Haw Loeung (hloeung) on 2011-06-01
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed
tags: added: ubiquity-2.6.5
tags: added: natty

Exception during installation:
Apr 15 23:20:07 ubuntu plugininstall.py: Traceback (most recent call last):
Apr 15 23:20:07 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1528, in <module>
Apr 15 23:20:07 ubuntu plugininstall.py: install.run()
Apr 15 23:20:07 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 56, in wrapper
Apr 15 23:20:07 ubuntu plugininstall.py: func(self)
Apr 15 23:20:07 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 197, in run
Apr 15 23:20:07 ubuntu plugininstall.py: self.configure_bootloader()
Apr 15 23:20:07 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 837, in configure_bootloader
Apr 15 23:20:07 ubuntu plugininstall.py: "GrubInstaller failed with code %d" % ret)
Apr 15 23:20:07 ubuntu plugininstall.py: InstallStepError: GrubInstaller failed with code 1
Apr 15 23:20:07 ubuntu plugininstall.py:

tags: added: installer-crash
Brian Murray (brian-murray) wrote :

Grub installer information:

Apr 15 23:20:06 ubuntu grub-installer: info: architecture: amd64/efi
Apr 15 23:20:06 ubuntu grub-installer: info: Identified partition label for /dev/sda2: gpt
Apr 15 23:20:07 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub
Apr 15 23:20:07 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-legacy
Apr 15 23:20:07 ubuntu grub-installer: dpkg: dependency problems prevent removal of grub-pc:
Apr 15 23:20:07 ubuntu grub-installer: grub-gfxpayload-lists depends on grub-pc (>= 1.99~20101210-1ubuntu2).
Apr 15 23:20:07 ubuntu grub-installer: dpkg: error processing grub-pc (--purge):
Apr 15 23:20:07 ubuntu grub-installer: dependency problems - not removing
Apr 15 23:20:07 ubuntu grub-installer: Errors were encountered while processing:
Apr 15 23:20:07 ubuntu grub-installer: grub-pc

affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Changed in grub-installer (Ubuntu):
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 7652570, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers