Ubuntu

Activity log for bug #720558

Date Who What changed Old value New value Message
2011-02-17 07:18:31 Paul Sladen bug added bug
2011-02-17 11:55:31 Paul Sladen description Binary package hint: debian-installer Forwarded from a kind source outside; this was found and documented (for their customers) by a Xen-based hosting company: Ubuntu 10.04 LTS does not install out-of-the-box with default settings on (virtual) machine requiring pvgrub and it is necessary to manually adjust the 'groot=' setting in order to get the machine to boot. Viz; "Ubuntu 10.04 LTS is now on the install menu (well, it has been for some time), however the bootloader install which works seamlessly on debian fails under Ubuntu, the following is what you need during the install to make it a bootable system: ========= Ubuntu by default with guided partitioning uses ext4, which pvgrub won't understand, so don't choose "Guided - use entire disk", but choose "Guided - use entire disk and set up LVM", as this will make an ext2 /boot partition. Ubuntu will give a grub error when installing, you need to use the following workaround during the installation: When you get the grub error, choose continue, continue, execute a shell, continue chroot /target update-grub -y sed -i.orig 's:^# groot=.*:# groot=(hd0,0):' /boot/grub/menu.lst update-grub exit exit Continue without bootloader ========= Binary package hint: debian-installer Forwarded from a kind source outside; this was found and documented (for their customers) by a Xen-based hosting company: Ubuntu 10.04 LTS does not install out-of-the-box with default settings on (virtual) machine requiring pvgrub and it is necessary to manually adjust the 'groot=' setting in order to get the machine to boot. Viz; "Ubuntu 10.04 LTS is now on the install menu (well, it has been for some time), however the bootloader install which works seamlessly on debian fails under Ubuntu, the following is what you need during the install to make it a bootable system: ========= Ubuntu by default with guided partitioning uses ext4, which pvgrub won't understand, so don't choose "Guided - use entire disk", but choose "Guided - use entire disk and set up LVM", as this will make an ext2 /boot partition. Ubuntu will give a grub error when installing, you need to use the following workaround during the installation: When you get the grub error, choose continue, continue, execute a shell, continue chroot /target update-grub -y sed -i.orig 's:^# groot=.*:# groot=(hd0,0):' /boot/grub/menu.lst update-grub exit exit Continue without bootloader ========= Some further information received: <..> sladen: the more root cause is grub installer not populating device.map <..> sladen: it doesn't seem to get bios devices for xvda devices
2011-02-17 11:55:59 Paul Sladen bug task added grub2 (Ubuntu)
2011-09-23 10:27:07 Colin Watson affects debian-installer (Ubuntu) grub-installer (Ubuntu)
2011-09-23 10:27:07 Colin Watson grub-installer (Ubuntu): importance Undecided High
2011-09-23 10:27:07 Colin Watson grub-installer (Ubuntu): status New Triaged
2011-09-23 10:27:23 Colin Watson grub2 (Ubuntu): status New Triaged
2011-09-23 10:27:26 Colin Watson grub2 (Ubuntu): importance Undecided High
2011-09-23 13:25:32 Colin Watson affects grub2 (Ubuntu) grub (Ubuntu)
2011-09-23 16:15:19 Colin Watson grub-installer (Ubuntu): importance High Undecided
2011-09-23 16:15:19 Colin Watson grub-installer (Ubuntu): status Triaged Invalid
2011-09-23 16:20:26 Launchpad Janitor branch linked lp:~ubuntu-core-dev/grub/ubuntu
2011-09-23 16:22:31 Colin Watson nominated for series Ubuntu Lucid
2011-09-23 16:22:31 Colin Watson bug task added grub (Ubuntu Lucid)
2011-09-23 16:22:31 Colin Watson bug task added grub-installer (Ubuntu Lucid)
2011-09-23 16:22:31 Colin Watson nominated for series Ubuntu Maverick
2011-09-23 16:22:31 Colin Watson bug task added grub (Ubuntu Maverick)
2011-09-23 16:22:31 Colin Watson bug task added grub-installer (Ubuntu Maverick)
2011-09-23 16:22:31 Colin Watson nominated for series Ubuntu Natty
2011-09-23 16:22:31 Colin Watson bug task added grub (Ubuntu Natty)
2011-09-23 16:22:31 Colin Watson bug task added grub-installer (Ubuntu Natty)
2011-09-23 16:22:50 Colin Watson grub (Ubuntu): assignee Colin Watson (cjwatson)
2011-09-23 16:22:58 Colin Watson grub (Ubuntu Lucid): status New Triaged
2011-09-23 16:23:00 Colin Watson grub (Ubuntu Maverick): status New Triaged
2011-09-23 16:23:03 Colin Watson grub (Ubuntu Natty): status New Triaged
2011-09-23 16:23:06 Colin Watson grub-installer (Ubuntu Lucid): status New Invalid
2011-09-23 16:23:09 Colin Watson grub-installer (Ubuntu Maverick): status New Invalid
2011-09-23 16:23:11 Colin Watson grub-installer (Ubuntu Natty): status New Invalid
2011-09-23 16:23:14 Colin Watson grub (Ubuntu Lucid): importance Undecided High
2011-09-23 16:23:17 Colin Watson grub (Ubuntu Maverick): importance Undecided High
2011-09-23 16:23:20 Colin Watson grub (Ubuntu Natty): importance Undecided High
2011-09-23 16:23:24 Colin Watson grub (Ubuntu Lucid): assignee Colin Watson (cjwatson)
2011-09-23 16:23:26 Colin Watson grub (Ubuntu Maverick): assignee Colin Watson (cjwatson)
2011-09-23 16:23:30 Colin Watson grub (Ubuntu Natty): assignee Colin Watson (cjwatson)
2011-09-23 16:23:32 Colin Watson grub (Ubuntu Lucid): milestone ubuntu-10.04.4
2011-09-23 21:02:22 Launchpad Janitor grub (Ubuntu): status Triaged Fix Released
2011-09-23 21:17:41 Launchpad Janitor branch linked lp:~ubuntu-core-dev/grub/lucid-proposed
2011-09-23 21:28:35 Colin Watson description Binary package hint: debian-installer Forwarded from a kind source outside; this was found and documented (for their customers) by a Xen-based hosting company: Ubuntu 10.04 LTS does not install out-of-the-box with default settings on (virtual) machine requiring pvgrub and it is necessary to manually adjust the 'groot=' setting in order to get the machine to boot. Viz; "Ubuntu 10.04 LTS is now on the install menu (well, it has been for some time), however the bootloader install which works seamlessly on debian fails under Ubuntu, the following is what you need during the install to make it a bootable system: ========= Ubuntu by default with guided partitioning uses ext4, which pvgrub won't understand, so don't choose "Guided - use entire disk", but choose "Guided - use entire disk and set up LVM", as this will make an ext2 /boot partition. Ubuntu will give a grub error when installing, you need to use the following workaround during the installation: When you get the grub error, choose continue, continue, execute a shell, continue chroot /target update-grub -y sed -i.orig 's:^# groot=.*:# groot=(hd0,0):' /boot/grub/menu.lst update-grub exit exit Continue without bootloader ========= Some further information received: <..> sladen: the more root cause is grub installer not populating device.map <..> sladen: it doesn't seem to get bios devices for xvda devices Stable update justification: Impact: Part of a set of bugs rendering it impossible to install any Ubuntu release from Lucid onwards as a Xen guest using d-i. (The others are bug 857548 and bug 857662, which affect only Natty and Oneiric.) Development branch: Fixed in grub 0.97-29ubuntu63 in Oneiric. Patch: http://bazaar.launchpad.net/~ubuntu-core-dev/grub/lucid-proposed/revision/905?compare_revid=903, and similar for other releases. TEST CASE: Install in a Xen guest and watch it fail as described below, or not. You'll need to use the boot parameter 'apt-setup/proposed=true' to test the fix. Regression potential: A limited number of people are still using GRUB Legacy anyway. I'd be pretty surprised if this broke anything other than Xen, which was already broken in this situation anyway. Original report: Binary package hint: debian-installer Forwarded from a kind source outside; this was found and documented (for their customers) by a Xen-based hosting company: Ubuntu 10.04 LTS does not install out-of-the-box with default settings on (virtual) machine requiring pvgrub and it is necessary to manually adjust the 'groot=' setting in order to get the machine to boot. Viz; "Ubuntu 10.04 LTS is now on the install menu (well, it has been for some time), however the bootloader install which works seamlessly on debian fails under Ubuntu, the following is what you need during the install to make it a bootable system: ========= Ubuntu by default with guided partitioning uses ext4, which pvgrub won't understand, so don't choose "Guided - use entire disk", but choose "Guided - use entire disk and set up LVM", as this will make an ext2 /boot partition. Ubuntu will give a grub error when installing, you need to use the following workaround during the installation: When you get the grub error, choose continue, continue, execute a shell, continue chroot /target update-grub -y sed -i.orig 's:^# groot=.*:# groot=(hd0,0):' /boot/grub/menu.lst update-grub exit exit Continue without bootloader ========= Some further information received: <..> sladen: the more root cause is grub installer not populating device.map <..> sladen: it doesn't seem to get bios devices for xvda devices
2011-09-23 21:44:01 Colin Watson grub (Ubuntu Lucid): status Triaged In Progress
2011-09-23 21:44:04 Colin Watson grub (Ubuntu Maverick): status Triaged In Progress
2011-09-23 21:44:05 Colin Watson grub (Ubuntu Natty): status Triaged In Progress
2011-09-26 15:42:07 Martin Pitt grub (Ubuntu Natty): status In Progress Fix Committed
2011-09-26 15:42:09 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2011-09-26 15:42:14 Martin Pitt bug added subscriber SRU Verification
2011-09-26 15:42:20 Martin Pitt tags verification-needed
2011-09-26 15:48:20 Martin Pitt grub (Ubuntu Maverick): status In Progress Fix Committed
2011-09-26 15:49:00 Martin Pitt grub (Ubuntu Lucid): status In Progress Fix Committed
2011-09-27 13:57:13 Martin Pitt tags verification-needed verification-done verification-done-lucid verification-needed
2011-09-27 16:56:11 Colin Watson tags verification-done verification-done-lucid verification-needed verification-done verification-done-lucid verification-done-natty verification-needed
2011-09-27 22:59:28 Colin Watson tags verification-done verification-done-lucid verification-done-natty verification-needed verification-done verification-done-lucid verification-done-natty verification-failed-maverick verification-needed
2011-09-28 00:00:32 Colin Watson grub (Ubuntu Maverick): status Fix Committed In Progress
2011-09-28 05:09:52 Martin Pitt grub (Ubuntu Maverick): status In Progress Fix Committed
2011-09-28 05:10:06 Martin Pitt tags verification-done verification-done-lucid verification-done-natty verification-failed-maverick verification-needed verification-done verification-done-lucid verification-done-natty verification-needed
2011-09-30 15:08:29 Colin Watson tags verification-done verification-done-lucid verification-done-natty verification-needed verification-done
2011-10-03 17:06:31 Launchpad Janitor grub (Ubuntu Lucid): status Fix Committed Fix Released
2011-10-03 17:07:10 Launchpad Janitor grub (Ubuntu Natty): status Fix Committed Fix Released
2011-10-05 16:43:58 Launchpad Janitor grub (Ubuntu Maverick): status Fix Committed Fix Released
2012-04-24 07:54:18 Launchpad Janitor branch linked lp:ubuntu/maverick-updates/grub
2012-04-24 07:54:21 Launchpad Janitor branch linked lp:ubuntu/lucid-updates/grub
2012-04-24 07:54:24 Launchpad Janitor branch linked lp:ubuntu/natty-proposed/grub
2012-04-24 07:54:30 Launchpad Janitor branch linked lp:ubuntu/grub