setting nomodeset in grub, if live session was started with nomodeset

Bug #664526 reported by P4man on 2010-10-21
112
This bug affects 26 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
grub-installer (Ubuntu)
High
Colin Watson
Precise
High
Unassigned
Raring
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Posting this as bug because I want to nominate it for 100 papercuts.

Some machines require nomodeset option to boot in to the GUI. For that reason, the livecd has this option more or less (*) conveniently accessible from the boot menu, using F6 key.

However, when this option is selected for the live session, ubiquity will install ubuntu and not set "nomoset' as default option. As a result, the machine will reboot and the user will unnecessarily almost guaranteed again face a black screen, and this time, with no F6 menu to solve it, instead this time requiring complicated grub editing in a menu that is again hidden by default and not even a clue there is one (grub), and then more advanced editing of grub defaults. This is an impossible task for any new user, and a unnecessary one.

If the live session is booted with nomodeset (and possibly other settings like safe graphics), ubiquity should recognise this and either set those same settings as default, or prompt the user and ask if he wants to retain those settings for his install (and it should default to yes).

(*) IMO its "less" rather than "more"; that menu on the livecd is hidden too well for a new user. Ive been using ubuntu for years and I didnt realise the keyboard logo meant I could press a key to open a menu. Why arent these options available in the menu where you select language and keyboard? Just have an "advanced" button or something. But thats another issue I suppose.

A paper cut is defined as: »A trivially fixable usability bug that the average user would encounter in default installation of Ubuntu or Kubuntu Desktop Edition«.

Since this bug is only valid for »some machines« and the fix does not seem trivial, this can not be addressed as part of the Paper Cuts project.

Don’t worry though, it will still be registered as a bug in ubiquity. For more criteria on paper cuts, please see https://wiki.ubuntu.com/PaperCut

Changed in hundredpapercuts:
status: New → Invalid
P4man (duvel123) wrote :

Fair enough.
I thought it would be a trivial fix (after all, it only requires checking /proc/cmdline, a simple dialogue and setting or not the same parameters in /etc/default/grub).

Wether or not it affects the "average" user.. well I havent met the average user, but it affects many that need one or another kernel option (nomodeset, apci_osi=linux, noapic/nolapic etc). The issue is the same for all of these, as is the proposed fix.

No worries though, hopefully it will inspire someone to include this in 11.04 :)

William Meilahn (bill-meilahn) wrote :

Amen to impossible for new users.

codeslinger (codeslinger) wrote :

since no survey has ever been done, it is impossible to know how many people this affects. To assume that the number is trivially small is a serious mistake.

Ubuntu seems to be going the way of microsoft... hiding everything from the user and making even simple things terribly difficult, with this straight-jacket mentality.

My grandmother is never going to repartition her disk and install ubuntu. so trying to design the interface for people like my grandmother and at the expense of more technical users is a no-win situation.

I've been promoting ubuntu for years and even converted a couple of businesses to using it (successfully). But it is bugs like this and the plymoth mess and the new cellphone like ubiquity interface, that have me and *thousands* of others on the very brink of abandoning ubuntu. Canonical claims to care, but nobody seems to be listening!!!

In fact, I'm on my way now to go download some other distros, because sadly I just can't keep fighting with this. Natty is the end of the line... As many others have tried to tell you, Natty is your Vista.... but all people are getting in response are deaf ears.

Paul Sladen (sladen) wrote :

codeslinger: there are far more people involved in Ubuntu than just those who happen to work at Canonical for some hours each week. That you've taken your own time to post a note here on this bug report also shows that you /yourself/ do care.

codeslinger (codeslinger) wrote :

"ubiquity interface" er uh, I meant to say "Unity interface"

========

Sure we care, but Canonical is calling all the shots, and lately for some inexplicable reason they have been heading in the wrong direction at a rapid gallop.

On the subject of Paper Cuts:

trying to target an os to the unskilled users like my grandmother, is all very fine and well as long as it's not being done at the expense of the technical users. But a lot of the things that they are doing are really alienating the technical users, and they ought to be the true target market.

glacial progress on bug fixes does not help to instill confidence either... the problems of PulseAudio for instance, are not Canonicals fault, but the choice to continue to use something that is so throughly broken is a policy choice of Canonical.

Maybe it is xorg that is to blame as well, but in ubuntu 9 on my old laptop everything worked. in Ubuntu 10 on my old laptop I couldn't get the video to work so never installed it. Then I got a new laptop. in ubuntu 10 on my new laptop everything works except the microphone. but now in ubuntu 11 on my new laptop the video once again does not work and the microphone still does not work. This is NOT progress.

Meanwhile the switch to the Unity Interface totally ignores the cost of retraining the unskilled users in how to use the new system -- that is even assuming the interface is any good, but by most accounts it is way too raw to deploy. Companies want stability, radical design changes without a compelling reason are not a good thing. That was in fact one of the selling points in converting people away from microsoft because they do make arbitrary changes strictly to have something new to sell and people have gotten fed up with that, but now ubuntu is doing the same.

I could go on... but basically what I am saying is that many of the trends are going in a negative direction and even if the problem is not with Canonical per-se they are the final arbitrator of ubuntu.

it is a sad sad thing, but thank you for the response.

I got here trying to run Ubuntu 11.4 and or LinuxMint 10 live CD/DVD. I get as far as Install it then a blank screen. Same thing with the next option safe install or some thing. What the heck are you lot talking about? Is there a site with plain talk for common basic snags? It seems my Nvidia video was not such a smart buy.

P4man (duvel123) wrote :

ichapman, maybe this howto helps:
http://ubuntuforums.org/showthread.php?t=1613132

It was written for 10.04 and 10.10, but I dont think anything has changed with 11.04 in that regard.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I am unsubscribing the sponsors team as there is no branch or patch to sponsor.

Colin Watson (cjwatson) wrote :

The options aren't available in the installer menu where you can select language and keyboard because that's too late; these are kernel options, and the kernel has already started by then.

I'm slightly bemused by this bug, though, because this is already how the installer is supposed to behave, and has been for many years; any boot parameters after the "--" separator are supposed to be copied into the installed system. If that's gone wrong then it is definitely not by intent.

no longer affects: ubiquity
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Colin Watson (cjwatson) on 2013-02-13
Changed in ubiquity (Ubuntu Raring):
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

This has indeed gone wrong at some point, judging by a test with a current raring daily. Investigating.

Changed in ubiquity (Ubuntu Raring):
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

The problem here is that we set the relevant configuration items by way of debconf preseeding, but that's only a useful way to do it if grub-pc isn't already installed - and it's been in our default live filesystems for at least three releases now (as far back as I cared to look). I'll need to change this to set configuration items directly in /etc/default/grub instead, which should work both for server and desktop installs.

affects: ubiquity (Ubuntu Raring) → grub-installer (Ubuntu Raring)
Colin Watson (cjwatson) wrote :

grub-installer fix uploaded. It'll need a ubiquity upload as well to take effect; those are reasonably frequent.

Changed in grub-installer (Ubuntu Precise):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
milestone: none → ubuntu-12.04.3
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.78ubuntu6

---------------
grub-installer (1.78ubuntu6) raring; urgency=low

  * Fix code that transfers user boot parameters into target system to work
    even when grub-pc is already installed, as in the case of installing
    with a live filesystem (LP: #664526).
 -- Colin Watson <email address hidden> Mon, 18 Feb 2013 14:29:41 +0000

Changed in grub-installer (Ubuntu Raring):
status: In Progress → Fix Released
Dario Ruellan (druellan) on 2013-02-18
Changed in hundredpapercuts:
status: Invalid → Fix Released
P4man (duvel123) wrote :

Reported by P4man on 2010-10-21

better late than never I guess :)

Colin Watson (cjwatson) wrote :

Yeah, sorry about that; I have way too many bugs to deal with, most of
them just as important ...

Pierre (pierrewinnipeg) wrote :

Would someone kindly answer that...

I was just working on the nomodeset issue, trying to replace in the Lubuntu Raring ISO boot menu the second option--INSTALL LUBUNTU--by TRY LUBUNTU WITHOUT INSTALLING (NOMODESET). I changed the option's title and added the 'nomodeset' to the boot parameters of the appropriate line in the isolinux/txt.cfg from which the boot menu is drawn. E.g.

1) TRY LUBUNTU WITHOUT INSTALLING (NORMAL MODE)
2) TRY LUBUNTU WITHOUT INSTALLING (NOMODESET)
With these boot paramaters:
  kernel /casper/vmlinuz
  append file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash nomodeset --

This way, it would be easier for new users with the NVidia problem to test & install the distro.

The question: If people decide to install, would the 'nomodeset' boot parameter be transfered by Ubiquity to new installation just as if someone had pressed F6 and selected 'nomodeset' to boot up with the ISO?

Second question: The nomodeset paramater is before the --. Should the correct boot parameters be this instead:
  append file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nomodeset

Thanks.

Colin Watson (cjwatson) wrote :

Parameters before the "--" will not be transferred. Parameters after
the "--" should be transferred. That is the purpose of the "--"
separator.

Pierre (pierrewinnipeg) wrote :

Colin,

Thanks a lot for your prompt answer.

I assume whether people use the F6 key + nomodeset or a TRY LUBUNTU WITHOUT INSTALLING (NOMODESET) option with built-in boot parameters:
  append file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nomodeset

the system will install with nomodeset in the boot parameters. Is this correct?

(sorry for being picky about details but I am not as familiar with this as you are and there is nothing worse for a newbie to install a system and boot to a black screen... just want to confirm that what I am planning to do will work)

Thanks.

Colin Watson (cjwatson) wrote :

I believe so, yes. Test it though. :-)

Colin Watson (cjwatson) on 2014-12-18
Changed in grub-installer (Ubuntu Precise):
assignee: Colin Watson (cjwatson) → nobody
milestone: ubuntu-12.04.3 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers