grub-installer ignores grub2/linux_cmdline_default in preseed

Bug #581796 reported by joschi on 2010-05-17
98
This bug affects 20 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: grub-installer

Description: Ubuntu 10.04
Release: 10.04

When automatically installing a system with a preseed file, grub-installer seems to ignore settings for grub2/linux_cmdline_default.

I have tried the following two lines in my preseed file, but none of them worked:

grub-pc grub2/linux_cmdline_default string
d-i grub2/linux_cmdline_default string

When running `debconf-get-selections` on the newly installed system, the output still contains:

grub-pc grub2/linux_cmdline_default string quiet splash

This seems to be an error (or at least an undocumented nuisance) of grub-installer ignoring the settings in the preseed file.

Colin Watson (cjwatson) on 2010-05-18
Changed in grub-installer (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Mathieu Mitchell (mat128) wrote :

Note to anyone trying to make this work, we are using these lines in preseed/late_command:
 sed -i 's/\(GRUB_CMDLINE_LINUX_DEFAULT=\).*/\1\"\"/g' /target/etc/default/grub; \
 in-target bash -c 'update-grub'; \

To set GRUB_CMDLINE_LINUX_DEFAULT to "". I read in another bug that the intended behaviour for Ubuntu Server was to not have the splash, only the quiet option. Our systems got installed using both quiet and splash all the time using netinst.

This late_command allows us to have a completely verbose boot process.

Mathieu Mitchell (mat128) wrote :

I just noticed LP truncated my line in 2. Make sure both are on individual lines and there is not space next to the backslash.

Alan Sparks (alan-l-sparks) wrote :

Still not fixed as of 12.04.

Jason Sievert (jsievert) wrote :

Seeing this one as well in 12.10.

Rick White (rickatnight11) wrote :

Still not fixed in 13.04.

Is there any chance to have a fix on Precise Pangolin?

Jeffrey Zhang (jeffrey4l) wrote :

Still no fixed in 14.04

Cory Wright (corywright) wrote :

Is there still hope for a fix to this 5 year old bug? I need this for our 14.04 systems.

Jeff Goldschrafe (jgoldschrafe) wrote :

Hi. It's 2016 now and this is still a problem in Xenial! Can someone look at this?

Remco Lamee (remco1hier) wrote :

I've been trying to fix our preseed installs as well, and I found the preseed entry that works: (tested on xenial beta2)

d-i debian-installer/add-kernel-opts string net.ifnames=0 quiet splash elevator=noop

debconf-get-selections doesn't mention this parameter in the output, but is does work because dmesg confirms that the options are passed to the boot image:

[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic root=UUID=123 ro net.ifnames=0 elevator=noop quiet splash

Martin Bergman (martin-devsed) wrote :

Still no fix in 16.04.2.

Could not use Remco's fix in my preseed either.

Andrew Lamarra (amlamarra) wrote :

Still no fix in Ubuntu 16.04.5.

Mathieu Mitchell (mat128) wrote :

The documentation for bionic mentions the new option, "debian-installer/add-kernel-opts":
https://help.ubuntu.com/lts/installation-guide/amd64/apbs04.html

Note however that there is a mention of "if supported by the bootloader installer".
Andrew: can you post full preseed file?

There is also a mention of "options passed to the installer will be added automatically", so maybe you can try passing kernel options through the installer kernel options?

Daniel Speichert (dasp) wrote :

@mat128 The problem is not with adding parameters (that indeed works) but removing them.
The "quiet splash" is added by default and there's no option to get rid of it easily.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers