serial console output does not work

Bug #514021 reported by Mark Bergsma on 2010-01-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub2

After installing Ubuntu 9.10 server edition using a serial console (on ttyS1), Grub2 fails to use the serial console as output device, and instead displays the following error messages:

error: bad unit number
error: unknown command `terminal'
error: unknown command `terminal'

These are the contents of /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="console=ttyS1,115200n8"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"
GRUB_TERMINAL=serial
GRUB_SERIAL_COMMAND="serial --unit=1 --speed=115200 --word=8 --parity=no --stop=1"

Joel Ebel (jbebel) wrote :

This was fixed in grub-installer 1.49ubuntu5 in Lucid. This was fixed in bug https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/524637 which I didn't realize was really a duplicate of this bug when I filed it.

affects: grub2 (Ubuntu) → grub-installer (Ubuntu)
Changed in grub-installer (Ubuntu):
status: New → Fix Released
Mark Bergsma (mark-wikimedia) wrote :

I don't think this was the same bug, as it's still happening with grub-installer 1.49ubuntu11.2 installs in Lucid.

Joel Ebel (jbebel) wrote :

My change fixed the problem for us. I apologize if I closed your bug prematurely. Unfortunately, I don't have access to re-open the bug, nor do I work on Ubuntu anymore. I suggest you open a new bug if this is still an issue for you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers