ubiquity crashed with InstallStepError in configure_bootloader()

Bug #421873 reported by Dave Morley on 2009-08-31
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

This error maybe similar to others however I am reporting it individually as it was from a wubi install. Please feel free to add it to others if it is the case that it is connected :)

ProblemType: Crash
Architecture: i386
Date: Mon Aug 31 10:44:49 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090830)
Package: ubiquity 1.99.13
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --automatic --only
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-8.28-generic
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--automatic', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with InstallStepError in configure_bootloader()
Uname: Linux 2.6.31-8-generic i686
UserGroups:

Dave Morley (davmor2) wrote :
tags: removed: need-duplicate-check
Dave Morley (davmor2) on 2009-09-01
visibility: private → public
Dave Morley (davmor2) wrote :

debug log

Dave Morley (davmor2) wrote :

New syslog

Colin Watson (cjwatson) on 2009-09-01
affects: ubiquity (Ubuntu) → grub-installer (Ubuntu)
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package grub-installer - 1.42ubuntu1

---------------
grub-installer (1.42ubuntu1) karmic; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Show the grub menu and raise the menu timeout if other operating
      systems are installed (only for GRUB Legacy right now).
    - Ask grub-installer/only_debian at medium priority.
    - Remove splash boot parameter unless debian-installer/framebuffer=true.
    - If / or /boot are on a removable device, install GRUB there by
      default.
    - Only mount /target/proc if it isn't already mounted.
    - Support setting OVERRIDE_UNSUPPORTED_OS in the environment to force
      grub-installer to use its default MBR selection method despite there
      being unsupported operating systems on the disk.
    - Unless grub-installer/make_active is preseeded to false, mark the
      partition to which GRUB is being installed as bootable, or failing
      that the first available primary partition on the disk to which GRUB
      is being installed.
    - Support grub-installer/bootdev_directory preseeding to make use of the
      relative path feature of grub4dos, so that we can point grub4dos at
      part of a disk for Wubi. Setting this disables normal grub
      installation, but still generates a device.map; it also hides the
      menu.
    - Handle cases where /boot is bind-mounted.
    - Add support for writing an GRUB Legacy MBR on each disk in an
      mdadm-managed RAID providing /boot. (GRUB 2 can handle this already.)
    - Properly make use of output from os-prober to configure the booting of
      other operating systems on dmraid arrays. Attempt to guess where in
      the device map the array belongs, by substituting the first drive in
      the dmraid array for the dmraid array device node itself, and removing
      any reference to other member disks of the array.
    - Set a sensible default boot device when /cdrom is not iso9660, as this
      is probably a USB install and (hd0) does not make sense when
      installing from a removable disk.
    - Go back to using update-grub -y for GRUB Legacy for now; our grub
      package is a bit old and still requires this.
    - Default to grub2 for GPT systems.
    - Allow grub/grub2 choice for ext4, though still default to grub2.
  * Restrict code to generate device.map for loop installations to GRUB
    Legacy (LP: #421873).
  * Fix said code to run grub chrooted into /target.

grub-installer (1.42) unstable; urgency=low

  [ Felix Zielcke ]
  * Check that /etc/kernel-img.conf exists before running sed over it.

  [ Colin Watson ]
  * Don't create /etc/grub.d/30_otheros if os-prober is already installed
    for grub2 to use (LP: #419044).
  * Pass user parameters to grub2 (closes: #470894).
  * Add myself to Uploaders.

  [ Updated translations ]
  * Korean (ko.po) by Changwoo Ryu

grub-installer (1.41) unstable; urgency=low

  [ Colin Watson ]
  * Merge from Ubuntu:
    - Add support for Ubuntu's lpia architecture ("Low-Power Intel
      Architecture").
  * Upgrade to debhelper v7.

  [ Felix Zielcke ]
  * Add support for /dev/rs/c[0-9]d[0-9] style devices.

  [ Luca Favatella ]
  * Add support for /d...

Read more...

Changed in grub-installer (Ubuntu):
status: New → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers