fails to deal with non-ASCII characters returned by os-prober

Bug #39505 reported by Bleck on 2006-04-13
8
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Medium
Unassigned

Bug Description

When installing PC 64 dapper flight 6 from CD, the installer does not see that a Win XP System is present. So the grub menu built by the installer won't show it.

The installation was made on a HP ze2000. Dapper was installed on hda2 (single partition) while Win XP was on hda1.

Colin Watson (cjwatson) wrote :

Please attach /var/log/installer/syslog to this bug.

Changed in os-prober:
status: Unconfirmed → Needs Info

I've updated the packages since the installation. Don't know if it modifies this log...

I just installed Dapper Flight 6 and it saw my Win XP perfectly. Maybe your hard drive layout or Win XP installation is someway special?

Bleck (bleck) wrote :

Same propblem happend with Dapper 32 bits. The drive layout seems OK and Mandriva installers (Mandriva one and PowerPack 2006) generate correct lilo configuration.

Bleck (bleck) wrote :

The same problem has been reported by someone else (bug 36854):

https://launchpad.net/distros/ubuntu/+source/grub/+bug/36854

Colin Watson (cjwatson) wrote :

grub-installer isn't dealing properly with the non-ASCII character in the description of your Windows partition returned by os-prober. From the log:

Apr 14 20:22:41 grub-installer: info: unhandled: /dev/discs/disc0/part1:Microsoft Windows XP
Apr 14 20:22:41 grub-installer: info: unhandled: dition familiale:Windows:chain

Changed in os-prober:
status: Needs Info → Confirmed
Bleck (bleck) wrote :

Since theses non-ASCII chars are those of the pre-installed french Family Edition (édition familiale) of Win XP that came with this HP Laptop, this bug will appear quite often...

Adam Niedling (krychek) wrote :

The original reporter was using an alpha version of Ubuntu. Please update this report if this is still an issue in Dapper Final or Hardy.

Changed in grub-installer:
status: Confirmed → Invalid
Colin Watson (cjwatson) wrote :

Invalid closure; reopening.

Changed in grub-installer:
status: Invalid → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers