Ubuntu

"you need to load the kernel first"

Reported by Patrice Vetsel on 2009-06-15
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: grub2

I'v installed Karmic 06/15/2009 daily iso on a new partition (sda5). Grub2 is installed and karmic boot right.

Trying to boot on my first partition (sda1) with Jaunty, using jaunty in grub2 menu.

I get this error message : "you need to load the kernel first"

Patrice Vetsel (vetsel-patrice) wrote :

grub.cfg

Felix Zielcke (fzielcke) wrote :

The first partition in grub2 would be hd0,1 not hd0,0 like you have.
known bug in grub-installer but in Debian this is now fixed.

Patrice Vetsel (vetsel-patrice) wrote :

Change to grub-installer

affects: grub2 (Ubuntu) → grub-installer (Ubuntu)
Felix Zielcke (fzielcke) wrote :

Colin Watson commited just now a real fix for this problem.
Mine was just using UUIDs but he fixed it for real that it now uses the correct numbering with grub2.

Changed in grub-installer (Ubuntu):
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

Indeed, thanks Felix. I've uploaded grub-installer 1.39ubuntu1 now, which includes this fix.

grub-installer (1.39) unstable; urgency=low

  * Merge from Ubuntu:
    - Use rootnoverify rather than root when chain-loading Microsoft
      operating systems using GRUB Legacy, since we may not be able to mount
      the partition (LP: #10661). From my reading of its code, this doesn't
      seem to be necessary with GRUB 2.
  * Extend rescue mode plugin to cope with GRUB 2.
  * Allow /boot on LVM; this forces use of GRUB 2 (LP: #393432).
  * Adjust partition offsets for GRUB 2. Moving to grub-probe would probably
    be better in the long run, but this works for now. See #473401, #502446.
  * Use search --fs-uuid rather than --fs_uuid in otheros.sh (LP: #396587).

 -- Colin Watson <email address hidden> Wed, 08 Jul 2009 15:30:14 +0100

Changed in grub-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Fix Committed → Fix Released
pitwalker (pitwalker) wrote :

Now I get the same error with the first boot entry after an upgrade.

-rw-r--r-- 1 root root 628340 2009-09-25 10:18 abi-2.6.31-11-generic
-rw-r--r-- 1 root root 629174 2009-11-10 18:52 abi-2.6.31-15-generic
-rw-r--r-- 1 root root 0 2009-12-01 19:45 bootlist
-rw-r--r-- 1 root root 111218 2009-09-25 10:18 config-2.6.31-11-generic
-rw-r--r-- 1 root root 111371 2009-11-10 18:52 config-2.6.31-15-generic
drwxr-xr-x 2 root root 4096 2009-12-01 18:52 grub
-rw-r--r-- 1 root root 7638352 2009-11-30 22:15 initrd.img-2.6.31-11-generic
-rw-r--r-- 1 root root 7640955 2009-12-01 18:58 initrd.img-2.6.31-15-generic
-rw-r--r-- 1 root root 128796 2009-10-23 16:11 memtest86+.bin
-rw-r--r-- 1 root root 1657331 2009-09-25 10:18 System.map-2.6.31-11-generic
-rw-r--r-- 1 root root 1665323 2009-11-10 18:52 System.map-2.6.31-15-generic
-rw-r--r-- 1 root root 1196 2009-09-25 10:21 vmcoreinfo-2.6.31-11-generic
-rw-r--r-- 1 root root 1196 2009-11-10 18:55 vmcoreinfo-2.6.31-15-generic
-rw-r--r-- 1 root root 3873888 2009-09-25 10:18 vmlinuz-2.6.31-11-generic
-rw-r--r-- 1 root root 3892224 2009-11-10 18:52 vmlinuz-2.6.31-15-generic

Changed in grub-installer (Ubuntu):
status: Fix Released → New
Akkana Peck (akkzilla) wrote :

I see this error trying to boot autogenerated entries in the grub2 menu, using grub2 from karmic. For entries I make myself in 40_custom, the kernel loads and then says it can't mount the root filesystem, regardless of whether I use root=sda5 or root=UUID=...

Pelias (peliaas) wrote :

Yay, this bug (OR MORE POSSIBLY, IT'S DERIVATIVE) just reared it's head on wubi with 10.40 daily.

Long story short, I cannot boot with new kernel image. Old kernel image works ok.

Dean Guilberry (mark-afm) wrote :

I had this problem on 9.10 update to from Linux version 2.6.31-14-generic to Linux version 2.6.31-20-generic
After kernel update I got the must load kernel first message.
It apperas that grub cannot load kernels if they are located beyond the 1st 4Gig of drive space.

I found a patch to WUBI file (wubildr file). If was on source forge and had a link to update the file
http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:Wubi_9.10

I was already booted into an old kernel that still worked (.14)and I didnt want to wait for windows 7 to slow boot just to replace one file so i just renamed the old wubildr file and copied the new downloaded on into its place from ubuntu 2.6.31-14. (from Linux file is located in /host directory)
After replacing this file reboot and choose latest kernel. I am writing this note from kernel 2.6.31-20. WOO HOO!!!

Mark

Phillip Susi (psusi) wrote :

I am moving this back to fix released since the issue as originally described was fixed. If you have a similar issue please file a new bug rather than change this one back to new.

Changed in grub-installer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments