Lenovo Ideapad 320-15IAP unable to install on UEFI - Grub install crashes

Bug #1832282 reported by nycnikato
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

This particular laptop has issues installing Grub in UEFI. For Ubuntu and many others Limux distro . Ultimately I have worked on this error and always get an input/output error in efibootmgr. So i am not sure if this still counts as a Grub issue or if it is ultimately solely an efibootmgr issue. Whether I install to sda or sda1 I get the same issue.. by the way, the error in efibootmgr is unable to register the boot entry input/output error. I am certain the issue is not related to space. To test it I tried to install bootloader to an sda1 partition with 8000MB of space. Is there someplace on the motherboard perhaps that needs to be wiped clean somehow? I do not know. I hope all of this info helps

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: ubiquity 19.04.9 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CasperVersion: 1.405
Date: Mon Jun 10 20:11:42 2019
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
nycnikato (nycnikato) wrote :
nycnikato (nycnikato)
summary: - Lenovo Ideapad 320 unable to install on UEFI - Grub install crashes
+ Lenovo Ideapad 320-15IAP unable to install on UEFI - Grub install
+ crashes
Revision history for this message
nycnikato (nycnikato) wrote :

I have new information which may help this laptop and many others. Apparently a change in the Logic of the installer may fix this issue for this laptop and many others. I have obtained this information from a friend who develops for EndlessOS. He expolains why EndlessOS installs so well on stubborn systems:

Endless, unlike other distributions, copies their bootloader to the fallback location (EFI/BOOT/bootx64.efi) on the EFI partition. Other distributions don't do that because they don't want to fight with Windows for ownership of this fallback boot loader. And your laptop is one the few bad ones that always boots the fallback entry regardless of what is in the EFI variables.

So, here are your options:

Install Debian, or install Ubuntu using the alternative installer. When booting the installer, select Advanced options > Expert install. When asked about installation of the boot loader into the removable media path, say Yes.
Install any other distribution. Fix up the incomplete installation by booting the installer in rescue mode. All you need to do is to copy grubx64.efi from its original location to EFI/BOOT/bootx64.efi. Or, if Secure Boot is enabled, copy shim.efi to EFI/BOOT/bootx64.efi instead, and also copy grubx64.efi near it.
Hopefully this list of md5sums from an Endless 3.5 VM will help. fallback.efi is something Endless-specific that fixes the boot order, but you should not need that.

75238f560aee0c2c1ff8fd8059de162f ./EFI/BOOT/fallback.efi
2a03c6987a88764801ce51e5e4ad3ad8 ./EFI/BOOT/bootia32.efi
7661abbf92a68466a3562ec887365e6a ./EFI/BOOT/bootx64.efi
23f901ffd8afd7d4077d415319acae70 ./EFI/endless/MokManager.efi
6d4a0f0e0d9770450313ab8223c95672 ./EFI/endless/grubx64.efi
ead39d2076f31634eef2ac4b2638d1e6 ./EFI/endless/BOOT.CSV
7661abbf92a68466a3562ec887365e6a ./EFI/endless/shim.efi

So perhaps a way around this bug is just to change the assumptions that the installer makes when someone decides they want to wipe the drive clean. I would be ok if Installing alongside windows fails.
I should add that the alternative installer approach failed.

Thanks to u/patrakov on Reddit.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Revision history for this message
Luciel borges de souza (cabecao41) wrote :

Ola meu amigo nycnikato tudo bom me deparei com esse problema no meu leptop lenovo ideapad 320 contudo irei realizar esse procedimento que você relator pra ver se contorno esse problema

no meu ocorre que não tenho como instalar o ubuntu em modo UEFI erro ocorre no grub.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers