Add option to disable NVRAM update

Bug #1800011 reported by Adam Smith on 2018-10-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub-installer (Debian)
New
Unknown
grub-installer (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

On armhf and arm64 U-boot is now capable of acting as UEFI. This is great for devices such as the raspberry pi. However, grub-installer currently always tries to update NVRAM which is non existent on the pi.

I was going to write a patch to add a preseedable option to disable NVRAM, but I see somebody has already submitted one to debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=789798

Changed in grub-installer (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
Changed in grub-installer (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.