[efi on top of legacy] Show a warning that installation will fail if user doesn't create an ESP partition or fallback to grub-pc

Bug #1783996 reported by Jean-Baptiste Lallement on 2018-07-27
104
This bug affects 14 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Unassigned
Cosmic
High
Unassigned
partman-partitioning (Ubuntu)
High
Łukasz Zemczak
Cosmic
High
Łukasz Zemczak

Bug Description

Test Case:
1. On a EFI machine with an existing system installed in BIOS mode (without an ESP partition), boot 18.04.1 (in EFI mode)
2. Select manual partitioning
3. Resize the main partition
4. Allocate the free space to Ubuntu and do not create an ESP partition
5. Proceed with the installation

Result
Grub setup and installation fail.

Given it'll always fail the installer should either display a warning (same message than when a new partition table is created in manual partitioning mode and an ESP partition is not created) or completely forbid the type of setup and prevent the user from confirming the new partitioning scheme if he didn't create an ESP partition.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14.6 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CasperVersion: 1.394
Date: Fri Jul 27 08:57:31 2018
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper ---
LiveMediaBuild: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
tags: added: rls-bb-incoming rls-cc-incoming
description: updated
Changed in grub-installer (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
Changed in grub-installer (Ubuntu):
importance: Undecided → Critical
summary: [efi on top of legacy] Show a warning that installation will fail if
- user doesn't create an ESP partition
+ user doesn't create an ESP partition or fallback to grub-pc
Brian Murray (brian-murray) wrote :

I've unmarked this as a duplicate of bug 1704510 as this bug has a clear test case and already has an assignee.

tags: added: id-5b75a90adf7d181d4f150b55
Phillip Susi (psusi) wrote :

Then I guess the duplicates should flow the other way even though the other report is a year older.

Changed in grub-installer (Ubuntu Cosmic):
importance: Critical → High
Changed in grub-installer (Ubuntu Cosmic):
status: Confirmed → In Progress
Changed in partman-partitioning (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in grub-installer (Ubuntu Cosmic):
status: In Progress → Invalid
Changed in partman-partitioning (Ubuntu Cosmic):
importance: Undecided → High
Changed in grub-installer (Ubuntu Cosmic):
assignee: Łukasz Zemczak (sil2100) → nobody
summary: - [efi on top of legacy] Show a warning that installation will fail if
- user doesn't create an ESP partition or fallback to grub-pc
+ [UIFe] [efi on top of legacy] Show a warning that installation will fail
+ if user doesn't create an ESP partition or fallback to grub-pc
Łukasz Zemczak (sil2100) wrote :

Had to change the wording of the warning message slightly, but after consulting with a few other developers it seems that an UIFe is not required as those messages weren't translated before. As per Matt's checks, it doesn't look like this is part of ubiquity's imported templates either.

Fix uploaded to the queue.

summary: - [UIFe] [efi on top of legacy] Show a warning that installation will fail
- if user doesn't create an ESP partition or fallback to grub-pc
+ [efi on top of legacy] Show a warning that installation will fail if
+ user doesn't create an ESP partition or fallback to grub-pc
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-partitioning - 120ubuntu2

---------------
partman-partitioning (120ubuntu2) cosmic; urgency=medium

  * On EFI systems, make sure there's an ESP partition present regardless of
    whether there's GPT or non-GPT partitions. We need to assume the user is
    unaware of the consequences. (LP: #1783996)
  * Change the wording of the missing ESP partition text to fit more all the
    cases we are trying to handle.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Wed, 10 Oct 2018 16:41:48 +0200

Changed in partman-partitioning (Ubuntu Cosmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers