grub-installer raid handling code missing nvme from sed filter

Bug #1771845 reported by Hans van den Bogert on 2018-05-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned
Cosmic
High
Unassigned

Bug Description

[Impact]
Installs on NVMe hardware, on RAID deployments (RAID made of NVMe devices).

[Test case]
- Install Ubuntu on NVMe drives, configure the drives in RAID.

[Regression potential]
Attention should be taken to the behavior of installs, especially on RAID arrays: given the changes to the device matching, failure to recognize some devices that should be part of the RAID array, or to see devices outside of the RAID array when they were not added to the array, should be investigated as potential regressions coming from this change.

--

It appears that Ubuntu patched grub-installer to handle raid arrays, duplicating some sed filters from earlier parts of the code. Debian probably added nvme to the earlier parts but the duplicate in the Ubuntu specific raid code did not get the same update. It needs the same update, and probably the whole raid handling part needs upstreamed to Debian.

Hans van den Bogert (hbogert) wrote :

The attachment "pc-mdadm-nvme.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub-installer (Ubuntu):
status: New → Confirmed
petski (petski) wrote :
Phillip Susi (psusi) on 2018-06-12
Changed in grub-installer (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
summary: - Cannot install on RAID1 in case the devices are NVMe
+ grub-installer raid handling code missing nvme
summary: - grub-installer raid handling code missing nvme
+ grub-installer raid handling code missing nvme from sed filter
description: updated
tags: added: rls-cc-incoming
tags: removed: rls-cc-incoming
tags: added: id-5b2bdb4e160d3f44f421a6f6
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.128ubuntu12

---------------
grub-installer (1.128ubuntu12) cosmic; urgency=medium

  [ Hans van den Bogert ]
  * Fix support for installation on NVMe with RAID1 (LP: #1771845)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 06 Jul 2018 13:16:28 -0400

Changed in grub-installer (Ubuntu Cosmic):
status: Triaged → Fix Released

Hello Hans, or anyone else affected,

Accepted grub-installer into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/grub-installer/1.128ubuntu8.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub-installer (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

@Hans,

Could you help verifying that this fix is working? I don't have access to any NVMe hardware.

Thanks!

@mathieu, I have to see if there's time at work to do this. Fyi, when I was
hit with this bug, I debugged this further with qemu which can emulate nvme
devices pretty easily.

On Mon, Jul 16, 2018, 19:26 Mathieu Trudel-Lapierre <email address hidden>
wrote:

> @Hans,
>
> Could you help verifying that this fix is working? I don't have access
> to any NVMe hardware.
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1771845
>
> Title:
> grub-installer raid handling code missing nvme from sed filter
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1771845/+subscriptions
>

Hans van den Bogert (hbogert) wrote :

@mathieu, I have to see if there's time at work to do this. Fyi, when I was hit with this bug, I debugged this further with qemu which can emulate nvme devices pretty easily.

Dimitri John Ledkov (xnox) wrote :

Using 18.04.0 installer, and trying to install into mdadm device, guided installation, fails in BIOS mode, whne mdadm device consists of two nvme partition devices e.g. /dev/nvme1n1p1 /dev/nvme0n1p1.

Using the latest bionic-server daily, with the grub-installer 1.128ubuntu8.18.04.2 install works and boots fine.

I was not able to succeed installing similar setup using UEFI and Linux raid, which is somewhat expected, as that's not supported (i.e. to have ESP on top of linux raid).

The BIOS-only reproducer, and validation of the fix, is sufficient to validate this SRU.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Hans van den Bogert (hbogert) wrote :

I can confirm it works:

- Tested with Qemu, BIOS (not uefi)
- 2 NVMe devices, each:
  - GPT
  - 1 biosgrub partition
  - 2x raid

2x Raid1 partitions, for '/' and '/boot'.

If actual hardware test is needed, please let me know.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.128ubuntu8.18.04.2

---------------
grub-installer (1.128ubuntu8.18.04.2) bionic; urgency=medium

  [ Hans van den Bogert ]
  * Fix support for installation on NVMe with RAID1 (LP: #1771845)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 06 Jul 2018 13:13:09 -0400

Changed in grub-installer (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for grub-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.