Install crashed: Unable to install bootloader at specified location

Bug #1722594 reported by j1n3l0 on 2017-10-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Tried to install over existing ubuntu 17.04 gnome installation. Worked fine up to the point I was presented with the error: "Unable to install bootloader at specified location". I was also unable to cancel the installation even though it was presented as an option.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.7
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CasperVersion: 1.384
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 10 17:43:42 2017
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 LC_NUMERIC=C.UTF-8
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

j1n3l0 (nelo-onyiah) wrote :
Phillip Susi (psusi) wrote :

You tried to install grub to /dev/dm-0, which is an LVM logical volume. It must be installed to a hard disk, such as /dev/sda.

Changed in grub-installer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers