Testing Alpha 2 install couldnt install grub

Bug #1708880 reported by Leandro Heck on 2017-08-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Tried on 2 disks, same output.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity 17.10.2
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
CasperVersion: 1.384
Date: Sat Aug 5 17:39:16 2017
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170804)
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LC_NUMERIC=C.UTF-8
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Leandro Heck (leoheck) wrote :
Ross Gammon (rosco2) wrote :

Just tried installing Artful 17.10 Ubuntu Studio 1st Beta into a Virtual Box VM that already had an installation of Artful daily.
I got an "Executing grub-install /dev/dm-0 failed. This is a fatal error" error. So I installed onto sda instead and the installation completed. But the VM will not reboot, just a stuck cursor in the top left.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1708880

tags: added: iso-testing
Ross Gammon (rosco2) on 2017-08-31
summary: - Tensting Alpha 2 install couldnt install grub
+ Testing Alpha 2 install couldnt install grub
Phillip Susi (psusi) wrote :

You are trying to install grub to /dev/sda, which is partitioned with GPT, but you are performing a BIOS mode install. This requires you to create a 1 mb bios_grub partition, or install grub to an MBR partitioned disk ( and make sure your bios is set to boot from that disk ).

Changed in grub-installer (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers