Ubuntu 16.04 - grub-efi-amd64-signed failed to install into /target/

Bug #1585592 reported by Matheus Castro
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu

Ubuntu 16.04 LTS - Release: 16.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

ubiquity 2.21.63 [modified: lib/partman/automaticaly_partition/question]

3) What you expected to happen

Install Ubuntu 16.04 on a 16GB USB flash disk (following this tutorial: http://ubuntuhandbook.org/index.php/2014/11/install-real-ubuntu-os-usb-drive/ )

4) What happened instead

<pre>
May 25 10:31:24 ubuntu systemd[1]: Starting Network Manager Script Dispatcher Service...
May 25 10:31:24 ubuntu dbus[1410]: [system] Successfuly activated service 'org.freedesktop.nm_dispatcher'
May 25 10:31:24 ubuntu systemd[1]: Started Network Manager Script Dispatcher Service...
May 25 10:31:24 ubuntu nm-dispatcher: req:1 'dhcp4-change' [enp3s0]: new request (1 script)
May 25 10:31:24 ubuntu nm-dispatcher: req:1 'dhcp4-change' [enp3s0]: start running ordered scripts...
</pre>

Popup window: GRUB installation failed
"The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot."

Probably, I forgot to disable secure boot on BIOS...?

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubiquity 2.21.63 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
Date: Wed May 25 07:56:52 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash ---
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Matheus Castro (matruskan) wrote :
Revision history for this message
Phillip Susi (psusi) wrote :

Your disk is currently partitioned to boot in bios mode, but you booted the 16.04 installer in EFI mode. A warning message prompted you that this could be a problem and recommended performing a bios mode install instead, but you chose not to. You either need to perform the bios mode install, or partition the disk using GPT and set up an EFI system partition to install in EFI mode. This will be done for you if you choose the "use entire disk" guided install option.

Changed in grub-installer (Ubuntu):
status: New → Invalid
Revision history for this message
Matheus Castro (matruskan) wrote :

Thank you.

Revision history for this message
Patrick Quinn-Graham (uo-3) wrote :

I'm getting this same error, except, psusi says:

"A warning message prompted you that this could be a problem and recommended performing a bios mode install instead, but you chose not to"

No it didn't.

"This will be done for you if you choose the "use entire disk" guided install option."

I chose this option and it still doesn't work.

Revision history for this message
Paddy Landau (paddy-landau) wrote :

I am getting this error as well, but the message that @Phillip Susi describes did not happen with me. The disk is correctly partitioned for UEFI. I am a bit lost as to how to diagnose and fix it.

Changed in grub-installer (Ubuntu):
status: Invalid → New
Revision history for this message
Franklin (franklin-goodhorse) wrote :

I'm still suffering from this problem.

When installing without internet connection, it would fail with this error messages (attachment 20_05_30.png). Under this state, the /var/log/syslog showed that it couldn't find package "grub-efi-amd64-signed" and "shim-signed", which actually existed in the pool/ folder in the live USB (attachment 20_05_20.png).

I don't think it a GPT EFI-partition problem since I selected "using the whole hard drive" and let the installer automatically partitioned it. The partition table is "Valid GPT with protective MBR", as attachment 20_06_19.png).

With internet connected, it would succeed sometimes (but not always).

I think the problem is that, when installing grub-efi-amd64-signed it couldn't read the CDROM repository. When internet connected it may find the package in the repository other than the CDROM one. But I couldn't find out why and had no idea about how to solve it.

Revision history for this message
Franklin (franklin-goodhorse) wrote :

Add screenshot of /var/log/syslog

Revision history for this message
Franklin (franklin-goodhorse) wrote :

Screenshot of partition tables, which shows that the ubiquity partitioned the hard drive with "valid GPT with protective MBR" and EFI partition was created.

Revision history for this message
Phillip Susi (psusi) wrote :

Please file your own bug report instead of reopening and hijacking someone else's.

Changed in grub-installer (Ubuntu):
status: New → Invalid
Revision history for this message
damien (gognoscranes) wrote :

The bug is Ubuntu 16.04 - grub-efi-amd64-signed failed to install into /target/ Despite Phillip Susi suggestion to partition the disk using GPT and set up an EFI system partition to install in EFI mode. This will be done for you if you choose the "use entire disk" guided install option.

THIS WILL only work if you follow Franklin suggestion to "use entire disk" whilst connected to the net.... Why you are so rude Phillip and why you keep marking this invalid when there is a clear issue is ridiculous. Thank you Franklin

Revision history for this message
Phillip Susi (psusi) wrote :

Lubuntu fails if you are not connected to the net, which is tracked in bug #1633913, but that is unrelated to this bug report.

Revision history for this message
lljccoael (lljccoael-deactivatedaccount) wrote :

"The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot."

Shove it up your ass, Phillip.

The fact this has been idiotically and repeatedly marked as Invalid while being unbelievably rude to reporters is a disgrace to the Ubuntu community.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers