Ubuntu

[Gutsy Beta] Desktop CD doesn't put Gutsy in Grub

Reported by Aaron Whitehouse on 2007-09-29
8
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: grub-installer

I just attempted to install Gutsy Beta from the Desktop CD. I have 256MB of RAM, so the Desktop CD only works sometimes and very slowly. Out of six attempts, I was able to launch ubiquity twice. After going through all of Ubiquity and waiting for it to install and set up all the packages, it tells me to take out the disc and reboot.

Upon rebooting, my Windows and Feisty installs are in the Grub list, but my new Gutsy install is not.

I have a partition for Windows, a Swap, / and /home partition for Feisty and 5 GB at the end of the disc that I am installing Gutsy into.

Any idea why it isn't doing the Grub update properly?

Any questions, just ask.

Shane Huang (shane-huang) wrote :

I think my case is similar as yours:

I tried to install 7.10 beta desktop amd64 into my board, but I find that the GRUB
is not installed at all each time.
The installation exits at about 80-90% without any dialog asking me to continue use
live CD or reboot.

when I mount the root partition to some place /var/temp/
I find there is no grub in /etc and /boot, and there is no initrd image either.

I also met this same problem in 7.10 Tribe 5, the solution was to burn another CD
with another DVD-RW drive. But this method fails in 7.10 Beta, I have tried many
times but all in vain. I don't know the reason.

Can any guys give me some information? The GRUB installation option is selected
as default. Thanks.

HW info:
RS690+SB700
AMD64 processor

Aaron Whitehouse (luna-tick) wrote :

Could this be related to Bug #139041 ?

drtvasudevan (agnihot3) wrote :

 the bug exists in alternate cd too.
i tried to install install 7.10 beta alternate amd64 and it wont.
tried lilo option and that was installed.
drtv

Shane Huang (shane-huang) wrote :

The GRUB installation failure still exists on Ubuntu7.10 RC x86_64 with my same HW platform. :-(

Aaron Whitehouse (luna-tick) wrote :

Gutsy Final worked correctly for me.

Shane Huang (shane-huang) wrote :

well, the final release works on some of our RS690+SB700 boards, but failure still exists on some other boards,
anyway, it's good news.

Aaron Whitehouse (luna-tick) wrote :

Absolutely no issues with Hardy. Hardy also uses a low-memory environment to install, so low RAM systems should have fewer issues.

Roy Jamison (xteejx) wrote :

Marking Fix Released, as Aaron stated this being fixed in Hardy. Thank you.

Changed in grub-installer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers