server iso install fails during grub install

Bug #1427821 reported by Scott Moser on 2015-03-03
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Critical
Mathieu Trudel-Lapierre

Bug Description

$ ver="20150303" # could use 'ver=current'
$ url=http://cdimage.ubuntu.com/ubuntu-server/daily/$ver/vivid-server-amd64.iso

$ wget $url -O "${url##*/}"
$ md5sum vivid-server-amd64.iso
26727e6c4c03f2b920c7fa3d5abe269c vivid-server-amd64.iso

$ qemu-system-x86_64 -enable-kvm\
     -device virtio-net-pci,netdev=net00 -netdev type=user,id=net00 \
    -drive if=virtio,file=vda.img -boot d -cdrom vivid-server-amd64.iso -m 512

# walk through install with all defaults

install fails at grub stage.

I chose defaults for disk setup (lvm) and the chose 'install grub to MBR'.
The error message is:

--
Install the GRUB boot loader on a hard disk
      Unable to intsal GRUB in /dev/vda5
  Executing 'grub-install /dev/vda5' failed.
This is a fatal error.

Scott Moser (smoser) wrote :

Attaching logs.

description: updated
Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
Changed in ubuntu:
status: New → Confirmed
importance: Undecided → Critical

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1427821/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → debian-installer (Ubuntu)
Steve Langasek (vorlon) on 2015-03-10
Changed in debian-installer (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Steve Langasek (vorlon) wrote :

In the jenkins automated test at
<https://jenkins.qa.ubuntu.com/job/vivid-server-amd64-smoke-multi-lvm/>, this error first appears in build 86 on February 19. The test was failing with a different and unrelated error prior to that; it's not clear to me if this is a latent issue that was only exposed once an earlier bug was fixed.

As a first thing to investigate, there in fact was a grub-installer upload on Feb 19. I'll start by checking if it could be "as simple" as that upload breaking things.

Changed in debian-installer (Ubuntu):
status: Confirmed → In Progress

Looks like it really is the latest grub-intaller upload that breaks this; reverted. The fix should be available in a few moments.

affects: debian-installer (Ubuntu) → grub-installer (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.78ubuntu26

---------------
grub-installer (1.78ubuntu26) vivid; urgency=medium

  * Revert changes from 1.78ubuntu25:
    * grub_probe(): return a single line in BTRFS multi-disk RAID configurations
      - It breaks bootloader install on LVM. (LP: #1427821)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 10 Mar 2015 15:33:01 -0400

Changed in grub-installer (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers